summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEdward Thomson <ethomson@edwardthomson.com>2021-11-10 17:32:41 -0500
committerEdward Thomson <ethomson@edwardthomson.com>2021-11-11 15:56:10 -0500
commit6c00fcb767b38c1902c0b1ca15350e7c5766e23d (patch)
treee0754f0884d6d3ed45d2200fe67ade2b178bf8d8 /CMakeLists.txt
parent789ab915607c3d91d8c04fd217de9bf37c631f5f (diff)
downloadlibgit2-6c00fcb767b38c1902c0b1ca15350e7c5766e23d.tar.gz
cmake: USE_SSH is not on by default
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c8825e966..040881f83 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -40,7 +40,7 @@ option(USE_THREADS "Use threads for parallel processing when possibl
option(USE_NSEC "Support nanosecond precision file mtimes and ctimes" ON)
# Backend selection
-option(USE_SSH "Link with libssh2 to enable SSH support" ON)
+option(USE_SSH "Link with libssh2 to enable SSH support" OFF)
option(USE_HTTPS "Enable HTTPS support. Can be set to a specific backend" ON)
option(USE_SHA1 "Enable SHA1. Can be set to CollisionDetection(ON)/HTTPS/Generic" ON)
option(USE_GSSAPI "Link with libgssapi for SPNEGO auth" OFF)