summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorWill Thompson <wjt@endlessos.org>2022-10-10 13:43:00 +0000
committerWill Thompson <wjt@endlessos.org>2022-10-10 13:43:00 +0000
commit8f2e676d9bf4d620e4b3e7b9b1cef382c1ae240f (patch)
treeb547bef7ae88e01af877c8ffb564806dbc2b58b6 /meson.build
parentf1e85346d277c3505b977d9b61111111a79fae4f (diff)
parent45108f1852d329b3a4d10f6d5d3558dca8288dcb (diff)
downloadlibglnx-8f2e676d9bf4d620e4b3e7b9b1cef382c1ae240f.tar.gz
Merge branch 'wip/smcv/warnings' into 'master'
build: Explicitly disable warnings for non-ISO C features See merge request GNOME/libglnx!42
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index c536c5b..a163e99 100644
--- a/meson.build
+++ b/meson.build
@@ -14,6 +14,11 @@ project(
add_project_arguments('-D_GNU_SOURCE', language: 'c')
add_project_arguments('-Wno-unused-local-typedefs', language: 'c')
+# We are intentionally using non-ISO features in this (sub)project,
+# even if a parent project wants to use pedantic warnings
+add_project_arguments('-Wno-pedantic', language: 'c')
+add_project_arguments('-Wno-variadic-macros', language: 'c')
+
cc = meson.get_compiler('c')