summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build42
1 files changed, 22 insertions, 20 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 555009f..2c38ab0 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -21,24 +21,26 @@ libglnx_testlib_dep = declare_dependency(
link_with : libglnx_testlib,
)
-test_names = [
- 'errors',
- 'fdio',
- 'macros',
- 'shutil',
- 'xattrs',
-]
+if get_option('tests')
+ test_names = [
+ 'errors',
+ 'fdio',
+ 'macros',
+ 'shutil',
+ 'xattrs',
+ ]
-foreach test_name : test_names
- exe = executable(test_name,
- [
- 'test-libglnx-' + test_name + '.c',
- ],
- dependencies: [
- libglnx_dep,
- libglnx_deps,
- libglnx_testlib_dep,
- ],
- )
- test(test_name, exe)
-endforeach
+ foreach test_name : test_names
+ exe = executable(test_name,
+ [
+ 'test-libglnx-' + test_name + '.c',
+ ],
+ dependencies: [
+ libglnx_dep,
+ libglnx_deps,
+ libglnx_testlib_dep,
+ ],
+ )
+ test(test_name, exe)
+ endforeach
+endif