summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorWerner Koch <wk@gnupg.org>2014-12-15 11:44:20 +0100
committerWerner Koch <wk@gnupg.org>2014-12-15 11:44:20 +0100
commit754a987f6df59e2ba0e69aada65ae4aaf593c148 (patch)
treeb1140ed7ae2de6dcb9342aa175b9e72a22e7701c /Makefile.am
parent923c4b174520c401a827d8198ebd2dc83666000f (diff)
downloadlibgpg-error-754a987f6df59e2ba0e69aada65ae4aaf593c148.tar.gz
Add configure option --disable-doc
* Makefile.am (doc) [!BUILD_DOC]: Do not recurse into doc/. * configure.ac (BUILD_DOC): New am_conditional and new option. -- We have this option already for GnuPG and should use it for all projects. Embedded platforms usually do not require documentation and being able to disable the building avoids a lot of build dependencies. Suggested-by: Hans-Christoph Steiner <hans@guardianproject.info>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index c6edd12..42cd0c4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -33,7 +33,13 @@ else
lang_subdirs =
endif
-SUBDIRS = m4 src doc tests po $(lang_subdirs)
+if BUILD_DOC
+doc = doc
+else
+doc =
+endif
+
+SUBDIRS = m4 src $(doc) tests po $(lang_subdirs)
dist-hook: gen-ChangeLog