summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorWerner Koch <wk@gnupg.org>2010-10-20 15:06:15 +0000
committerWerner Koch <wk@gnupg.org>2010-10-20 15:06:15 +0000
commit960df54ce8d479b42813dc14789cbf9299e207b0 (patch)
treef2857302a3dfa5f0361f5d13b833ebfe7aac76ce /Makefile.am
parentd717d13e27cb02fbbb015854e3811d9b0aad3c06 (diff)
downloadlibgpg-error-960df54ce8d479b42813dc14789cbf9299e207b0.tar.gz
Fix for W32CE.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 14 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index e55cd9f..d0d3000 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -20,7 +20,8 @@
ACLOCAL_AMFLAGS = -I m4
AUTOMAKE_OPTIONS = dist-bzip2
-EXTRA_DIST = autogen.sh config.rpath libgpg-error.spec.in COPYING COPYING.LIB
+EXTRA_DIST = autogen.sh config.rpath libgpg-error.spec.in COPYING COPYING.LIB \
+ potomo
if LANGUAGES_SOME
lang_subdirs = lang
@@ -36,6 +37,18 @@ dist-hook:
$(top_srcdir)/libgpg-error.spec.in > $(distdir)/libgpg-error.spec
@set -e; echo "$(VERSION)" > $(distdir)/VERSION
+if HAVE_W32_SYSTEM
+install-data-hook:
+ set -e; \
+ for i in $$($(top_srcdir)/potomo --get-linguas $(top_srcdir)/po); do \
+ $(MKDIR_P) "$(DESTDIR)$(localedir)/$$i/LC_MESSAGES" || true; \
+ rm -f "$(DESTDIR)$(localedir)/$$i/LC_MESSAGES/libgpg-error.mo" \
+ 2>/dev/null || true; \
+ $(top_srcdir)/potomo $(top_srcdir)/po/$$i.po \
+ "$(DESTDIR)$(localedir)/$$i/LC_MESSAGES/libgpg-error.mo" ; \
+ done
+endif
+
stowinstall:
$(MAKE) $(AM_MAKEFLAGS) install prefix=/usr/local/stow/libgpg-error