summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorWerner Koch <wk@gnupg.org>2011-12-01 14:57:15 +0100
committerWerner Koch <wk@gnupg.org>2011-12-01 14:57:15 +0100
commit9d75d671d66386ad862db0466c4dd67a246dfe72 (patch)
tree5affa0ab5917652012ec0dd904154d357f24181e /Makefile.am
parentaaa3f53457369125bcfa6eeaf283df77df87d4f9 (diff)
downloadlibgpg-error-9d75d671d66386ad862db0466c4dd67a246dfe72.tar.gz
Generate the ChangeLog from commit logs.
* build-aux/gitlog-to-changelog: New script. Taken from gnulib. * build-aux/git-log-fix: New file. * build-aux/git-log-footer: New file. * doc/HACKING: New file. * ChangeLog: New file. * Makefile.am (EXTRA_DIST): Add new files. (gen-ChangeLog): New. (dist-hook): Run gen-ChangeLog. Rename all ChangeLog files to ChangeLog-2011.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am34
1 files changed, 26 insertions, 8 deletions
diff --git a/Makefile.am b/Makefile.am
index d0d3000..e92925b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,18 +1,18 @@
# Makefile.am for libgpg-error.
# Copyright (C) 2003, 2006, 2007 g10 Code GmbH
-#
+#
# This file is part of libgpg-error.
-#
+#
# libgpg-error is free software; you can redistribute it and/or modify
# it under the terms of the GNU Lesser General Public License as
# published by the Free Software Foundation; either version 2.1 of the
# License, or (at your option) any later version.
-#
+#
# libgpg-error is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
# GNU Lesser General Public License for more details.
-#
+#
# You should have received a copy of the GNU Lesser General Public
# License along with this program; if not, write to the Free Software
# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA
@@ -20,8 +20,11 @@
ACLOCAL_AMFLAGS = -I m4
AUTOMAKE_OPTIONS = dist-bzip2
-EXTRA_DIST = autogen.sh config.rpath libgpg-error.spec.in COPYING COPYING.LIB \
- potomo
+EXTRA_DIST = autogen.sh config.rpath libgpg-error.spec.in \
+ COPYING COPYING.LIB potomo doc/HACKING ChangeLog-2011 \
+ po/ChangeLog-2011m4/ChangeLog-2011 contrib/ChangeLog-2011 \
+ build-aux/gitlog-to-changelog build-aux/git-log-footer \
+ build-aux/git-log-fix
if LANGUAGES_SOME
lang_subdirs = lang
@@ -32,11 +35,26 @@ endif
SUBDIRS = m4 src tests po $(lang_subdirs)
-dist-hook:
+dist-hook: gen-ChangeLog
sed -e 's/@pkg_version@/$(VERSION)/g' \
$(top_srcdir)/libgpg-error.spec.in > $(distdir)/libgpg-error.spec
@set -e; echo "$(VERSION)" > $(distdir)/VERSION
+
+gen_start_date = 2011-12-01T00:00:00
+.PHONY: gen-ChangeLog
+gen-ChangeLog:
+ if test -d $(top_srcdir)/.git; then \
+ (cd $(top_srcdir) && \
+ ./build-aux/gitlog-to-changelog \
+ --amend=build-aux/git-log-fix \
+ --since=$(gen_start_date) ) > $(distdir)/cl-t; \
+ cat $(top_srcdir)/build-aux/git-log-footer >> $(distdir)/cl-t;\
+ rm -f $(distdir)/ChangeLog; \
+ mv $(distdir)/cl-t $(distdir)/ChangeLog; \
+ fi
+
+
if HAVE_W32_SYSTEM
install-data-hook:
set -e; \
@@ -49,6 +67,6 @@ install-data-hook:
done
endif
-stowinstall:
+stowinstall:
$(MAKE) $(AM_MAKEFLAGS) install prefix=/usr/local/stow/libgpg-error