summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNIIBE Yutaka <gniibe@fsij.org>2022-01-18 10:26:44 +0900
committerNIIBE Yutaka <gniibe@fsij.org>2022-01-18 10:26:44 +0900
commitb26220f92fa668e185dbf2bcc5006c6e74b20073 (patch)
treee8663cac9e09d86809ebd905c403680d6682a417 /Makefile.am
parentb37c68f28a921d1c03507469f4af53e012ef7679 (diff)
downloadlibgpg-error-b26220f92fa668e185dbf2bcc5006c6e74b20073.tar.gz
po,w32: Directly run msgfmt at install-data-hook.
* Makefile.am (EXTRA_DIST): Remove potomo. [HAVE_W32_SYSTEM] (install-data-hook): Run msgfmt. -- Note that all po files are now in UTF-8. Signed-off-by: NIIBE Yutaka <gniibe@fsij.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 7 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index b67a276..9e4563f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -34,7 +34,7 @@ DISTCHECK_CONFIGURE_FLAGS = --enable-doc
GITLOG_TO_CHANGELOG=gitlog-to-changelog
EXTRA_DIST = autogen.sh autogen.rc libgpg-error.spec.in \
- VERSION COPYING COPYING.LIB potomo doc/HACKING ChangeLog-2011 \
+ VERSION COPYING COPYING.LIB doc/HACKING ChangeLog-2011 \
po/ChangeLog-2011 m4/ChangeLog-2011 contrib/ChangeLog-2011 \
build-aux/git-log-footer build-aux/git-log-fix
@@ -103,12 +103,12 @@ gen-ChangeLog:
if HAVE_W32_SYSTEM
install-data-hook:
set -e; \
- for i in $$($(top_srcdir)/potomo --get-linguas $(top_srcdir)/po); do \
- $(MKDIR_P) "$(DESTDIR)$(localedir)/$$i/LC_MESSAGES" || true; \
- rm -f "$(DESTDIR)$(localedir)/$$i/LC_MESSAGES/libgpg-error.mo" \
- 2>/dev/null || true; \
- $(top_srcdir)/potomo $(top_srcdir)/po/$$i.po \
- "$(DESTDIR)$(localedir)/$$i/LC_MESSAGES/libgpg-error.mo" ; \
+ for i in $$(sed -e '/^#/d' -e 's/#.*//' $(top_srcdir)/po/LINGUAS); do \
+ $(MKDIR_P) "$(DESTDIR)$(localedir)/$$i/LC_MESSAGES" || true; \
+ rm -f "$(DESTDIR)$(localedir)/$$i/LC_MESSAGES/libgpg-error.mo" \
+ 2>/dev/null || true; \
+ msgfmt -o "$(DESTDIR)$(localedir)/$$i/LC_MESSAGES/libgpg-error.mo" \
+ $(top_srcdir)/po/$$i.po ; \
done
endif