summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2016-07-10 11:38:47 +0200
committerWerner Koch <wk@gnupg.org>2016-07-12 10:42:56 +0200
commitd57a16c3779eca84dedcf2423b26e41172cd5a96 (patch)
tree4b961f3688bee7049fa3505f45f35b2cbdd36bbe /Makefile.am
parentabcdfa7964da62b92984516608faf8941038b71d (diff)
downloadlibgpg-error-d57a16c3779eca84dedcf2423b26e41172cd5a96.tar.gz
Add an option to disable tests
* configure.ac: add an option to enable/disable building tests * Makefile.am: conditionally build tests -- On an embeded device, there is no reason to have the tests present in a production release build. Add a configure-time option to disable them. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index baeba14..5abd97d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -39,7 +39,13 @@ else
doc =
endif
-SUBDIRS = m4 src $(doc) tests po $(lang_subdirs)
+if BUILD_TESTS
+tests = tests
+else
+tests =
+endif
+
+SUBDIRS = m4 src $(doc) $(tests) po $(lang_subdirs)
dist-hook: gen-ChangeLog