summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNIIBE Yutaka <gniibe@fsij.org>2021-02-18 10:15:43 +0900
committerNIIBE Yutaka <gniibe@fsij.org>2021-02-18 10:15:43 +0900
commit1fb90a7da186ee2ee098a666f6f3a35bb1720e59 (patch)
treece49e46e1b952135d679e9c721ac32a9358357ea /configure.ac
parented3cd20de8d3eab92dd8fff02bcc214c55d08398 (diff)
downloadlibgpg-error-1fb90a7da186ee2ee098a666f6f3a35bb1720e59.tar.gz
build: Support --disable-threads by gen-lock-obj.sh.
* configure.ac: Supply --disable-threads to gen-lock-obj.sh. Tighten the condition of using gen-lock-obj.sh for GNU/Linux. * src/gen-lock-obj.sh: Support --disable-threads. -- GnuPG-bug-id: 5296 Signed-off-by: NIIBE Yutaka <gniibe@fsij.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 8 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index b9a2a3e..7ec21b6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -595,9 +595,15 @@ if test "$have_w32_system" = yes; then
fi
force_use_syscfg=yes
fi
-if test x$cross_compiling = xyes; then
+if test x"$gl_use_threads" = xno; then
+ lock_obj_h_generated=yes
+ if test ! -d src; then mkdir src; fi
+ host=$host $srcdir/src/gen-lock-obj.sh --disable-threads \
+ >src/lock-obj-pub.native.h
+ AC_MSG_NOTICE([generated src/lock-obj-pub.native.h for $host])
+elif test x$cross_compiling = xyes; then
case $host in
- *-*-linux*)
+ *-*-linux-gnu*)
AC_CHECK_TOOL(OBJDUMP, [objdump])
if test -n "$OBJDUMP"; then
lock_obj_h_generated=yes