summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNIIBE Yutaka <gniibe@fsij.org>2021-11-25 12:08:58 +0900
committerNIIBE Yutaka <gniibe@fsij.org>2021-11-25 12:08:58 +0900
commit50e0f32b19356fd7c64c799192379ff2204cd8a3 (patch)
tree6728c3ec497c86355392f7f819a10f365f11d1f7 /configure.ac
parent0fcfca8e9ffa25836f391df75f5b3bb1b7dc1a69 (diff)
downloadlibgpg-error-50e0f32b19356fd7c64c799192379ff2204cd8a3.tar.gz
build,tests: Run t-lock-single-posix only on platforms supported.
* configure.ac (HAVE_LOCK_OPTIMIZATION): New. * tests/Makefile.am: Use HAVE_LOCK_OPTIMIZATION for t-lock-single-posix. -- GnuPG-bug-id: 5699 Signed-off-by: NIIBE Yutaka <gniibe@fsij.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f13b14c..c75d994 100644
--- a/configure.ac
+++ b/configure.ac
@@ -633,6 +633,15 @@ AM_CONDITIONAL(CROSS_COMPILING, test x$cross_compiling = xyes)
AM_CONDITIONAL(FORCE_USE_SYSCFG, test x$force_use_syscfg = xyes)
AM_CONDITIONAL(HAVE_GENERATED_LOCK_OBJ_H, test x$lock_obj_h_generated = xyes)
+have_lock_optimization=no
+if test "$gl_threads_api" = posix; then
+ if test x$ac_cv_header_sys_single_threaded_h = xyes \
+ -o x$gl_cv_have_weak = xyes; then
+ have_lock_optimization=yes
+ fi
+fi
+AM_CONDITIONAL(HAVE_LOCK_OPTIMIZATION, test "$have_lock_optimization" = yes)
+
AC_DEFINE_UNQUOTED(HOST_TRIPLET_STRING, "$host", [The host triplet])