summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWerner Koch <wk@gnupg.org>2014-08-26 17:56:44 +0200
committerWerner Koch <wk@gnupg.org>2014-08-26 17:56:44 +0200
commit7fdca61bcf60e730177889fbbd2f935ba33ae0c3 (patch)
tree80e9fcb444debc32dd1569bf033dad9dbaf28c7a /configure.ac
parentd9d5b61a9f70556e8fc0775f1501380f65ce9502 (diff)
downloadlibgpg-error-7fdca61bcf60e730177889fbbd2f935ba33ae0c3.tar.gz
Add gpgrt_set_alloc_func.
* src/visibility.c (gpgrt_set_alloc_func): New. * configure.ac (_ESTREAM_PRINTF_REALLOC): Define. (_ESTREAM_PRINTF_EXTRA_INCLUDE): Define. * src/estream.c (mem_alloc, mem_realloc, mem_free): Simplify. (_gpgrt_free): Remove. * src/init.c (custom_realloc): New var. (_gpgrt_set_alloc_func): New. (_gpgrt_realloc, _gpgrt_malloc, _gpgrt_free): New. * src/visibility.h (gpg_err_deinit): Mark as visible.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index cf0d37c..b155437 100644
--- a/configure.ac
+++ b/configure.ac
@@ -136,6 +136,11 @@ AH_BOTTOM([
#if defined(HAVE_W32_SYSTEM) && !defined(ENABLE_NLS)
#define ENABLE_NLS 1
#endif
+
+/* Connect the generic estream-printf.c to our framework. */
+#define _ESTREAM_PRINTF_REALLOC _gpgrt_realloc
+#define _ESTREAM_PRINTF_EXTRA_INCLUDE "gpgrt-int.h"
+
/* For building we need to define these macro. */
#define GPG_ERR_ENABLE_GETTEXT_MACROS 1
#define GPG_ERR_ENABLE_ERRNO_MACROS 1