summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNIIBE Yutaka <gniibe@fsij.org>2020-12-07 12:01:34 +0900
committerNIIBE Yutaka <gniibe@fsij.org>2020-12-07 12:01:34 +0900
commit9ee011259f819a3cf50fe7019fa4366dbc437e0e (patch)
treecefb7f39fc09cef18ff973c5f8c8fe1c322238c9 /configure.ac
parent8047ca99858a7ee812ef11ed3bd2868e920ac1b7 (diff)
downloadlibgpg-error-9ee011259f819a3cf50fe7019fa4366dbc437e0e.tar.gz
build: Use AC_CHECK_TOOL to detect objdump for cross build.
* configure.ac (CROSS_HOST_OBJDUMP): Remove, but use AC_CHECK_TOOL. -- Co-authored-by: John Ericson Signed-off-by: NIIBE Yutaka <gniibe@fsij.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 4928c31..f94900d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -598,12 +598,12 @@ fi
if test x$cross_compiling = xyes; then
case $host in
*-*-linux*)
- AC_CHECK_PROG(CROSS_HOST_OBJDUMP, [$host_alias-objdump], [yes])
- if test "$CROSS_HOST_OBJDUMP" = "yes" ; then
+ AC_CHECK_TOOL(OBJDUMP, [objdump])
+ if test -n "$OBJDUMP"; then
lock_obj_h_generated=yes
if test ! -d src; then mkdir src; fi
LOCK_ABI_VERSION=1 host=$host host_alias=$host_alias \
- CC=$CC OBJDUMP=$host_alias-objdump \
+ CC=$CC OBJDUMP=$OBJDUMP \
ac_ext=$ac_ext ac_objext=$ac_objext \
AWK=$AWK $srcdir/src/gen-lock-obj.sh \
>src/lock-obj-pub.native.h