summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMarcus Brinkmann <mb@g10code.com>2009-06-23 15:04:47 +0000
committerMarcus Brinkmann <mb@g10code.com>2009-06-23 15:04:47 +0000
commit845c2608bb343d4b5faa8e15628a9d6747668369 (patch)
tree24f1fa9e77621f1761b5221fde7c0f5ebd8ae971 /src/Makefile.am
parent44630d8bc9d312c7d9f7c2f803bd6a2c51dceac9 (diff)
downloadlibgpg-error-845c2608bb343d4b5faa8e15628a9d6747668369.tar.gz
2009-06-23 Marcus Brinkmann <marcus@g10code.de>
Update to libtool 2.2.6a. * configure.ac: Invoke AC_CONFIG_MACRO_DIR. (AC_LIBTOOL_WIN32_DLL, AC_LIBTOOL_RC): Replace by ... (LT_PREREQ, LT_INIT, LT_LANG): ... these. * config.guess, config.sub, install-sh, ltmain.sh, m4/libtool.m4: Updated to libtool 2.2.6a. * m4/ltoptions.m4, m4/ltsugar.m4, m4/ltversion.m4, m4/lt~obsolete.m4: New files from libtool 2.2.6a. * src/Makefile.am (LTRCCOMPILE): Refactor with ... (RCCOMPILE): ... this new macro. Add $(libgpg_error_la_CPPFLAGS). (SUFFIXES): Add .lo. (.rc.o): Change to ... (.rc.lo): ... this implicit rule. (gpg_error_res_ldflag): Removed. (gpg_error_res): Use libtool object file name here. (install-def-file): Fix typo. (libgpg_error_la_LDFLAGS): Remove gpg_error_res_ldflag usage. (libgpg_error_la_LIBADD): Add gpg_error_res.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am22
1 files changed, 10 insertions, 12 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 75ac960..6444c2c 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -50,22 +50,21 @@ CLEANFILES = err-sources.h err-codes.h code-to-errno.h code-from-errno.h \
if HAVE_W32_SYSTEM
arch_sources = w32-gettext.h w32-gettext.c
-LTRCCOMPILE = $(LIBTOOL) --mode=compile $(RC) \
- `echo $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) | \
- sed -e 's/-I/--include-dir /g;s/-D/--define /g'`
+RCCOMPILE = $(RC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) \
+ $(libgpg_error_la_CPPFLAGS) $(AM_CPPFLAGS) $(CPPFLAGS)
+LTRCCOMPILE = $(LIBTOOL) --mode=compile --tag=RC $(RCCOMPILE)
-SUFFIXES = rc
+SUFFIXES = .rc .lo
-.rc.o:
- $(LTRCCOMPILE) -i $< -o $@
+.rc.lo:
+ $(LTRCCOMPILE) -i "$<" -o "$@"
-gpg_error_res = versioninfo.o
-gpg_error_res_ldflag = -Wl,$(gpg_error_res)
+gpg_error_res = versioninfo.lo
no_undefined = -no-undefined
export_symbols = -export-symbols $(srcdir)/gpg-error.def
install-def-file:
- $(INSTALL) gpg-error.def $(DESTDIR)$(libdir)/gpg-error-.def
+ $(INSTALL) gpg-error.def $(DESTDIR)$(libdir)/gpg-error.def
uninstall-def-file:
-rm $(DESTDIR)$(libdir)/gpg-error.def
@@ -76,7 +75,6 @@ intllibs =
else
arch_sources =
gpg_error_res =
-gpg_error_res_ldflag =
no_undefined =
export_symbols =
install-def-file:
@@ -87,7 +85,7 @@ intllibs = @LTLIBINTL@
endif
-libgpg_error_la_LDFLAGS = $(gpg_error_res_ldflag) -version-info \
+libgpg_error_la_LDFLAGS = -version-info \
@LIBGPG_ERROR_LT_CURRENT@:@LIBGPG_ERROR_LT_REVISION@:@LIBGPG_ERROR_LT_AGE@ \
$(no_undefined) $(export_symbols)
@@ -95,7 +93,7 @@ libgpg_error_la_SOURCES = gpg-error.h gettext.h $(arch_sources) \
init.c strsource.c strerror.c code-to-errno.c code-from-errno.c
libgpg_error_la_CPPFLAGS = -DLOCALEDIR=\"$(localedir)\"
-libgpg_error_la_LIBADD = $(intllibs)
+libgpg_error_la_LIBADD = $(gpg_error_res) $(intllibs)
gpg_error_SOURCES = strsource-sym.c strerror-sym.c gpg-error.c $(arch_sources)
gpg_error_CPPFLAGS = -DLOCALEDIR=\"$(localedir)\"