summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorWerner Koch <wk@gnupg.org>2017-11-17 09:18:13 +0100
committerWerner Koch <wk@gnupg.org>2017-11-17 09:18:13 +0100
commit9c904765c9b2b75e73b196b381470f0fb2f3b458 (patch)
tree07a4e7f8017a1312a33065c14db0057cfa8b1ad3 /src/Makefile.am
parent1b441034eedbc3d95f516f325f053b3d9ba837f1 (diff)
downloadlibgpg-error-9c904765c9b2b75e73b196b381470f0fb2f3b458.tar.gz
New configure options and macros for internal use.
* configure.ac: Add option --enable-log-clock. * configure.ac: Add option --enable-werror. * src/sysutils.c: New. * src/Makefile.am (libgpg_error_la_SOURCES): Add sysutils.c * src/gpgrt-int.h: Add internal i18n macros and hacks to make working with sockets easier. (es_stdin, es_stdout, es_stderr): New internal macros. (snprintf): New macro. Signed-off-by: Werner Koch <wk@gnupg.org>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index e4ebb6a..3210a65 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -15,11 +15,14 @@
#
# You should have received a copy of the GNU Lesser General Public
# License along with this program; if not, see <https://www.gnu.org/licenses/>.
+# SPDX-License-Identifier: LGPL-2.1+
+
+#
# We distribute the generated sources err-sources.h and err-codes.h,
# because they are needed to build the po directory, and they don't
# depend on the configuration anyway.
-
+#
if HAVE_W32CE_SYSTEM
gpg_extra_headers = gpg-extra/errno.h
@@ -179,7 +182,12 @@ libgpg_error_la_SOURCES = gettext.h $(arch_sources) \
gpgrt-int.h init.c init.h version.c lock.h thread.h \
estream.c estream-printf.c estream-printf.h \
strsource.c strerror.c code-to-errno.c code-from-errno.c \
- visibility.c visibility.h b64dec.c
+ visibility.c visibility.h \
+ sysutils.c \
+ logging.c \
+ b64dec.c
+
+
nodist_libgpg_error_la_SOURCES = gpg-error.h
# libgpg_error_la_DEPENDENCIES = \