summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorWerner Koch <wk@gnupg.org>2014-08-25 13:33:12 +0200
committerWerner Koch <wk@gnupg.org>2014-08-25 16:37:46 +0200
commitce31fe792b5f8adf81710c1bf5986cd10636e16b (patch)
tree0efa8bcec71f95f2f5afaa90ed45b34eb5c8472b /tests/Makefile.am
parent8a5f2680daa5ea0280ef195efe3050df7bb06e78 (diff)
downloadlibgpg-error-ce31fe792b5f8adf81710c1bf5986cd10636e16b.tar.gz
Add test for the estream printf functions
* tests/t-printf.c: New. * configure.ac: Check for vasprintf. -- These tests have been taken from Libestream and changed to be more portable. For example there is only va_start per function and the test return an error only for _GLIBC_ based systems because that is what we compare against.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 388e1d5..0927e27 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -27,7 +27,7 @@ endif
gpg_error_lib = ../src/libgpg-error.la
-TESTS = t-version t-strerror t-syserror t-lock
+TESTS = t-version t-strerror t-syserror t-lock t-printf
INCLUDES = -I$(top_builddir)/src $(extra_includes)