summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorHans Ulrich Niedermann <gp@n-dimensional.de>2006-09-18 18:22:58 +0000
committerHans Ulrich Niedermann <gp@n-dimensional.de>2006-09-18 18:22:58 +0000
commit1ba914ae69ddb3baee3a0f17719622deadbcfb9f (patch)
tree039e81a3dea0a2e382f9b45e0ef91939b6960f0b /Makefile.am
parentc5a05047c6677f4caa1d5b6c172ebe8a5f90d27d (diff)
downloadlibgphoto2-1ba914ae69ddb3baee3a0f17719622deadbcfb9f.tar.gz
Fix gphoto2/*.h generation: Do it at one place, at the right time.
git-svn-id: https://svn.code.sf.net/p/gphoto/code/trunk/libgphoto2@9173 67ed7778-7388-44ab-90cf-0a291f65f57c
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 3 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index 5650cf21d..27fdb40b1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -8,7 +8,7 @@ bin_SCRIPTS = gphoto2-config
EXTRA_DIST = HACKING MAINTAINERS makefile.os2 os2mak.inc TESTERS CHANGES
# Note: @subdirs@ lists all the directories from AC_CONFIG_SUBDIRS()
-SUBDIRS = @subdirs@ libgphoto2 camlibs tests po bindings packaging doc
+SUBDIRS = . @subdirs@ libgphoto2 camlibs tests po bindings packaging doc
doc_DATA = AUTHORS COPYING README CHANGES NEWS
@@ -23,9 +23,8 @@ doc_DATA = AUTHORS COPYING README CHANGES NEWS
# - Helps build libgphoto2 frontends against libgphoto2 without
# installing libgphoto2 first.
#
-# This functionality is duplicated in configure.in in order to
-# set up the gphoto2/ directory before building other stuff. This
-# makes it possible to consistently use #include <gphoto2/stuff.h>.
+# This functionality requires the "." to be the first item in SUBDIRS
+# and makes it possible to consistently use #include <gphoto2/stuff.h>.
all-local:
@echo "Creating/Updating gphoto2/ directory with gphoto2*.h files"
@@ -39,9 +38,6 @@ all-local:
gphoto2/ > /dev/null 2>&1 \
|| true
-# This is also called by distclean, so we don't need a separate
-# distclean-local target as counterpart to the gphoto2/ creation
-# in the configure script.
clean-local:
rm -f gphoto2/gphoto2*.h
rmdir gphoto2 || true