summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorHans Ulrich Niedermann <hun@n-dimensional.de>2021-11-02 00:03:23 +0100
committerHans Ulrich Niedermann <hun@n-dimensional.de>2021-11-07 22:28:48 +0100
commit30ee10437b3463cf27a092a0c533ad9f7466e75d (patch)
tree3c1b664985324b84a0da510ab2e31cd2c398048b /Makefile.am
parente866cd22566427d33003e3544f3fd22633384f6f (diff)
downloadlibgphoto2-30ee10437b3463cf27a092a0c533ad9f7466e75d.tar.gz
Only use a single gphoto-m4/ subdir
Only use a single gphoto-m4/ subdir - namely that in libgphoto2_port/gphoto-m4/. This prevents us from needing to synchronize the contents of the gphoto-m4/ and the libgphoto2_port/gphoto-m4/ directories. We can do that by switching from recursive make for the gphoto-m4 subdirectories to using include path/to/gphoto-m4/Makefile-files from both the top-level Makefile.am and libgphoto2_port/Makefile.am using %reldir% (introduced in automake 1.14).
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index b0ccbe075..52050e2c5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -8,8 +8,8 @@ bin_SCRIPTS = gphoto2-config
EXTRA_DIST = MAINTAINERS TESTERS installcheck.mk
EXTRA_DIST += HACKING.md SECURITY.md
-# Note: @subdirs@ lists all the directories from AC_CONFIG_SUBDIRS()
-SUBDIRS = @subdirs@ libgphoto2 camlibs tests examples po packaging doc gphoto-m4
+# Note: $(subdirs) lists all the directories from AC_CONFIG_SUBDIRS()
+SUBDIRS = $(subdirs) libgphoto2 camlibs tests examples po packaging doc
EXTRA_DIST += libgphoto2.pc.in
pkgconfig_DATA = libgphoto2.pc
@@ -106,7 +106,9 @@ update-po:
########################################################################
# The following default options for aclocal and automake
-# are required in the top level Makefile.am for the automatic
+# are required in the top level Makefile.am for the automatic
# re-building of the build system files.
-ACLOCAL_AMFLAGS = -I auto-m4 -I gphoto-m4
+ACLOCAL_AMFLAGS = -I auto-m4 -I libgphoto2_port/gphoto-m4
+
+include libgphoto2_port/gphoto-m4/Makefile-files