summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorHans Ulrich Niedermann <gp@n-dimensional.de>2006-12-29 08:21:40 +0000
committerHans Ulrich Niedermann <gp@n-dimensional.de>2006-12-29 08:21:40 +0000
commit453010d1cfec92b69afc2a92b87a0016b419a433 (patch)
tree808a1506a356fd7fddb2c884f13e69453baa9215 /Makefile.am
parent51e4f0ae452870ea06198a9109dfa785697e0100 (diff)
downloadlibgphoto2-453010d1cfec92b69afc2a92b87a0016b419a433.tar.gz
Shortcut for selective camlib install: "make DRIVERS='canon.la ptp2.la' install-drivers"
git-svn-id: https://svn.code.sf.net/p/gphoto/code/trunk/libgphoto2@9760 67ed7778-7388-44ab-90cf-0a291f65f57c
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index dd488e9d4..94e9bf23a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -30,7 +30,7 @@ DISTCLEANFILES = libgphoto2/gphoto2-endian.h
# we use just ONE .PHONY target in order not to confuse automake
-.PHONY: rpm cvs-tags source-code-check
+.PHONY: rpm cvs-tags source-code-check install-drivers
########################################################################
# source code check maintenance task
@@ -50,6 +50,15 @@ source-code-check:
@echo "######## Finding explicit libintl.h references"
find . -type f -name '*.[ch]' -exec egrep -H '^#.*include.*libintl\.h' {} \;
+
+########################################################################
+# Shortcut for installation of a subset of camlibs/drivers
+# Usage: make DRIVER="canon.la ptp2.la" install-drivers
+
+install-drivers:
+ cd camlibs && $(MAKE) DRIVERS="$(DRIVERS)" install-drivers
+
+
########################################################################
# The following default options for aclocal and automake
# are required in the top level Makefile.am for the automatic
@@ -82,6 +91,7 @@ cvs-tags: Makefile
+########################################################################
# Compatibility for header inclusions.
#
# - Old code has -I/usr/include/gphoto2