summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorHans Ulrich Niedermann <gp@n-dimensional.de>2005-06-11 16:05:48 +0000
committerHans Ulrich Niedermann <gp@n-dimensional.de>2005-06-11 16:05:48 +0000
commit72f59fc98f31ee5a1b89eaab456a7e1a8736db82 (patch)
treef966a2225b370d90bc07ae740cfa00851ca0893e /Makefile.am
parent4b319414e16bf4dbc45fed2cc0325b091878f5c7 (diff)
downloadlibgphoto2-72f59fc98f31ee5a1b89eaab456a7e1a8736db82.tar.gz
make copying of header files less frightening (hide error messages)
git-svn-id: https://svn.code.sf.net/p/gphoto/code/trunk/libgphoto2@8063 67ed7778-7388-44ab-90cf-0a291f65f57c
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 6 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index a5159771e..3190a11ec 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -14,17 +14,18 @@ doc_DATA = AUTHORS COPYING README CHANGES NEWS
# Help for building packages against libgphoto2 without installing
# libgphoto2 first. A little hackish, but that's what you get for
-# having "libgphoto2" and "libgphoto2_port" install their header
+# having both "libgphoto2" and "libgphoto2_port" install their header
# files into $(includedir)/gphoto2.
all-local:
- rm -f gphoto2/gphoto2*.h
- mkdir -p gphoto2
- cp \
+ @echo "Creating/Updating gphoto2/ directory with gphoto2*.h files"
+ @rm -f gphoto2/gphoto2*.h
+ @mkdir -p gphoto2
+ @cp \
libgphoto2/gphoto2*.h \
libgphoto2_port/libgphoto2_port/gphoto2*.h \
$(srcdir)/libgphoto2/gphoto2*.h \
$(srcdir)/libgphoto2_port/libgphoto2_port/gphoto2*.h \
- gphoto2/ \
+ gphoto2/ > /dev/null 2>&1 \
|| true
clean-local: