summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorHans Ulrich Niedermann <gp@n-dimensional.de>2006-09-30 10:05:33 +0000
committerHans Ulrich Niedermann <gp@n-dimensional.de>2006-09-30 10:05:33 +0000
commit8754ac5d38eb9d9fadd8585665113baf7bcb5ee7 (patch)
treef53b5c0318e71985c1dedf135cff9765bfc557a1 /Makefile.am
parentfbc751fd8fd6fff53e25accf7688c39754099118 (diff)
downloadlibgphoto2-8754ac5d38eb9d9fadd8585665113baf7bcb5ee7.tar.gz
make really sure that gphoto2/ is removed
git-svn-id: https://svn.code.sf.net/p/gphoto/code/trunk/libgphoto2@9242 67ed7778-7388-44ab-90cf-0a291f65f57c
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index f7a42fb87..92668b96c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -13,9 +13,10 @@ SUBDIRS = . @subdirs@ libgphoto2 camlibs tests po bindings packaging doc
doc_DATA = AUTHORS COPYING README CHANGES NEWS
# Remove obsolete directory of copied/symlinked header files
+all-local:
+ if test -d gphoto2; then rm -f gphoto2/gphoto2*.h; rmdir gphoto2; fi
clean-local:
- rm -f gphoto2/gphoto2*.h
- rmdir gphoto2 || true
+ if test -d gphoto2; then rm -f gphoto2/gphoto2*.h; rmdir gphoto2; fi
# we use just ONE .PHONY target in order not to confuse automake