summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorHans Ulrich Niedermann <gp@n-dimensional.de>2006-09-28 03:04:21 +0000
committerHans Ulrich Niedermann <gp@n-dimensional.de>2006-09-28 03:04:21 +0000
commitc96bda51dd1b005649e0dfb9e9a70fce34d78486 (patch)
tree8458af3bf052e29bd07ac5102ff99ae25f90579e /Makefile.am
parent24f5c463e9f29cf69fbc4e51ef4e3e043da4801c (diff)
downloadlibgphoto2-c96bda51dd1b005649e0dfb9e9a70fce34d78486.tar.gz
Consistently use #include <gphoto2/gphoto2-foo.h> everywhere.
This moves the header files to a new subdirectory gphoto2 in both libgphoto2 and libphoto2_port/libgphoto2. All references are adapted appropriately. git-svn-id: https://svn.code.sf.net/p/gphoto/code/trunk/libgphoto2@9221 67ed7778-7388-44ab-90cf-0a291f65f57c
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am27
1 files changed, 1 insertions, 26 deletions
diff --git a/Makefile.am b/Makefile.am
index 27fdb40b1..1e16e47b3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -12,32 +12,7 @@ SUBDIRS = . @subdirs@ libgphoto2 camlibs tests po bindings packaging doc
doc_DATA = AUTHORS COPYING README CHANGES NEWS
-# Create gphoto2/ directory and copy all header files into it.
-#
-# Reasons to do that:
-# - Both libgphoto2 and libgphoto2_port install their *.h files
-# into $(includedir)/gphoto2
-# - Example programs can use #include <gphoto2/gphoto2-foobar.h>
-# like any libgphoto2 frontend is supposed to do.
-# (Promotes clean API use)
-# - Helps build libgphoto2 frontends against libgphoto2 without
-# installing libgphoto2 first.
-#
-# This functionality requires the "." to be the first item in SUBDIRS
-# and makes it possible to consistently use #include <gphoto2/stuff.h>.
-
-all-local:
- @echo "Creating/Updating gphoto2/ directory with gphoto2*.h files"
- @rm -f gphoto2/gphoto2*.h
- @mkdir -p gphoto2
- @cp \
- libgphoto2/gphoto2*.h \
- libgphoto2_port/libgphoto2_port/gphoto2*.h \
- $(srcdir)/libgphoto2/gphoto2*.h \
- $(srcdir)/libgphoto2_port/libgphoto2_port/gphoto2*.h \
- gphoto2/ > /dev/null 2>&1 \
- || true
-
+# Remove obsolete directory of copied/symlinked header files
clean-local:
rm -f gphoto2/gphoto2*.h
rmdir gphoto2 || true