summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorHans Ulrich Niedermann <hun@n-dimensional.de>2021-10-31 09:02:20 +0100
committerHans Ulrich Niedermann <hun@n-dimensional.de>2021-12-10 21:47:34 +0100
commitd18b440a72407fc371ec17a2a983976b813e5d97 (patch)
treeefe579a1ef9b0b856da3a7bd27de7a5cd03fb7c5 /Makefile.am
parentb2d8e106ae31b59e0ec9ecf9534376f97b9dbe1c (diff)
downloadlibgphoto2-d18b440a72407fc371ec17a2a983976b813e5d97.tar.gz
Require gettext >= 0.18.3; remove GP_GETTEXT_HACK
This requires gettext version 0.18.3 or later, and it removes the GP_GETTEXT_HACK which used to generate a po/Makevars file from the po/Makevers.template. gettext 0.18.3 is the same gettext version requirement as libexif uses. gettext 0.18.3 has been released 2013-07-07, which is a similar timeframe of the autoconf, automake and libtool releases we require. If you ever need to build a post 2021 libgphoto2 from git on a system with pre 0.18.3 gettext, you can can always prepare a tarball using "make dist" on a system with gettext 0.18.3 or later, and build that tarball on the older machine. Not generating the po/Makevars file any more means that we need additional consistency checks for the parts of po/Makevars which cannot be derived from the Autoconf standard set of AC_SUBST()ed Makefile.in variables.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 52050e2c5..322491115 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -103,6 +103,16 @@ git-checkout-po:
update-po:
@for d in $(PO_SUBDIRS); do (cd "$$d" && $(MAKE) $(AM_MAKEFLAGS) update-po) || exit 1; done
+@GP_GETTEXT_SETUP_MK@
+
+# Dummy target to force Automake to make the all target depend on it
+all-local:
+ @:
+
+# Dummy target to force Automake to make the distclean target depend on it
+distclean-local:
+ @:
+
########################################################################
# The following default options for aclocal and automake