summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorScott Fritzinger <scottf@unr.edu>2001-03-03 20:18:07 +0000
committerScott Fritzinger <scottf@unr.edu>2001-03-03 20:18:07 +0000
commita0014ce9544c0515e7ce76acc87db2cb78313c2c (patch)
tree539cf3eca8cea41e0fd83c71a620307caa0c2059 /configure.in
parent58e132fe2059de97dd84790fa67da812e7531ee0 (diff)
downloadlibgphoto2-a0014ce9544c0515e7ce76acc87db2cb78313c2c.tar.gz
fixed the build. readded sony dscf1 to build and fixed minor automake build problems with it
git-svn-id: https://svn.code.sf.net/p/gphoto/code/trunk/libgphoto2@1648 67ed7778-7388-44ab-90cf-0a291f65f57c
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in34
1 files changed, 24 insertions, 10 deletions
diff --git a/configure.in b/configure.in
index 1e81095d0..a4ec11822 100644
--- a/configure.in
+++ b/configure.in
@@ -51,15 +51,30 @@ dnl Checks for library functions.
AC_CHECK_FUNCS(mkdir strdup strncpy strcpy snprintf sprintf)
AC_PATH_PROG(LIBGPPORT_CONFIG,gphoto2-port-config)
+required_gphoto2_port_version=0.0.3
+USE_BUNDLED_GPPORT=1
if test -n "${LIBGPPORT_CONFIG}"; then
- LIBGPHOTO2_PORT_DIR=""
- CFLAGS="$CFLAGS `$LIBGPPORT_CONFIG --cflags`"
- LIBS="$LIBS `$LIBGPPORT_CONFIG --libs`"
- else
- dnl Use the bundled gphoto2_port
+
+ echo checking for gphoto2-port - version == $required_gphoto2_port_version
+ gphoto2_port_version=`$LIBGPPORT_CONFIG --version | \
+ sed 's/\(.*\) \(.*\)/\2/'`
+ if test -n "${gphoto2_port_version}"; then
+ if test "$required_gphoto2_port_version" = "$gphoto2_port_version" ; then
+ USE_BUNDLED_GPPORT=
+ fi
+ fi
+fi
+
+if test -n "${USE_BUNDLED_GPPORT}"; then
+ echo "Using the bundled gphoto2_port library"
LIBGPHOTO2_PORT_DIR="libgphoto2_port"
CFLAGS="$CFLAGS -I`pwd`/libgphoto2_port/include";
LIBS="$LIBS -L`pwd`/libgphoto2_port/libgphoto2_port/.libs -lgphoto2_port";
+ else
+ echo "Using the already-installed gphoto2_port library"
+ LIBGPHOTO2_PORT_DIR=""
+ CFLAGS="$CFLAGS `$LIBGPPORT_CONFIG --cflags`"
+ LIBS="$LIBS `$LIBGPPORT_CONFIG --libs`"
fi
LIBGPHOTO2_INCLUDEDIR='-I${includedir}'
@@ -79,9 +94,7 @@ AC_SUBST(LIBS)
dnl Find out which drivers to compile
-dnl Add the sonydscf1 back in!
-
-camlibs='barbie canon directory sierra konica panasonic digita kodak minolta stv0680'
+camlibs='barbie canon directory sierra konica panasonic digita kodak minolta stv0680 sonydscf1'
AC_SUBST(SUBDIRS_CAMLIBS)
for i in $camlibs; do
d=`echo $i | $TR a-z A-Z`
@@ -94,8 +107,8 @@ AC_ARG_WITH(drivers,
[ 'all' compiles all drivers; ]
[ possible drivers are: ]
[ barbie, canon, digita, directory, kodak, ]
- [ konica, minolta, panasonic, sierra sonydscf1 ]
- [ stv0680 ],
+ [ konica, minolta, panasonic, sierra, ]
+ [ sonydscf1 stv0680 ],
drivers="$withval", drivers="all")
if test "$drivers" = "all"; then
for i in $camlibs; do
@@ -140,6 +153,7 @@ camlibs/kodak/dc240/Makefile \
camlibs/kodak/dc3200/Makefile \
camlibs/minolta/Makefile \
camlibs/minolta/dimagev/Makefile \
+camlibs/sonydscf1/Makefile \
camlibs/stv0680/Makefile \
frontends/Makefile \
frontends/command-line/Makefile \