summaryrefslogtreecommitdiff
path: root/libgphoto2/Makefile.am
diff options
context:
space:
mode:
authorHans Ulrich Niedermann <gp@n-dimensional.de>2006-01-03 13:03:47 +0000
committerHans Ulrich Niedermann <gp@n-dimensional.de>2006-01-03 13:03:47 +0000
commit7b2e4c9e71e8b847dda00f3a5aa6030d6b140cd6 (patch)
tree645582b217247e3d1f4784660f35a726753c916c /libgphoto2/Makefile.am
parent169c8293115cffc44608f539459cc3f756cf88d8 (diff)
downloadlibgphoto2-7b2e4c9e71e8b847dda00f3a5aa6030d6b140cd6.tar.gz
add *.sym file to _DEPENDENCIES
git-svn-id: https://svn.code.sf.net/p/gphoto/code/trunk/libgphoto2@8401 67ed7778-7388-44ab-90cf-0a291f65f57c
Diffstat (limited to 'libgphoto2/Makefile.am')
-rw-r--r--libgphoto2/Makefile.am14
1 files changed, 7 insertions, 7 deletions
diff --git a/libgphoto2/Makefile.am b/libgphoto2/Makefile.am
index b8f14800a..cad2e10f3 100644
--- a/libgphoto2/Makefile.am
+++ b/libgphoto2/Makefile.am
@@ -1,10 +1,5 @@
lib_LTLIBRARIES = libgphoto2.la
-libgphoto2_la_CPPFLAGS = \
- $(LTDLINCL) \
- $(AM_CPPFLAGS) $(CPPFLAGS) \
- $(LIBEXIF_CFLAGS)
-
# Notes about the list of exported symbols:
# gp_* also contains internal symbols which are intended for
# INTERNAL USE ONLY and should be converted into gpi_* symbols
@@ -16,11 +11,16 @@ libgphoto2_la_CPPFLAGS = \
#
# Yes, this is messy, but we are going to clean this up.
+libgphoto2_la_CPPFLAGS = \
+ $(LTDLINCL) \
+ $(AM_CPPFLAGS) $(CPPFLAGS) \
+ $(LIBEXIF_CFLAGS)
+
libgphoto2_la_LDFLAGS = \
-no-undefined \
-export-symbols $(srcdir)/libgphoto2.sym \
-version-info @LIBGPHOTO2_VERSION_INFO@
-
+
libgphoto2_la_SOURCES = \
gphoto2-abilities-list.c\
bayer.c bayer.h \
@@ -49,9 +49,9 @@ libgphoto2_la_LIBADD = \
# "-dlopen" $(top_builddir)/camlibs/ptp2/....la
libgphoto2_la_DEPENDENCIES = \
+ $(srcdir)/libgphoto2.sym \
$(LIBLTDL)
-
libgphoto2includedir = $(includedir)/gphoto2
libgphoto2include_HEADERS = \
gphoto2.h \