summaryrefslogtreecommitdiff
path: root/libgphoto2_port/configure.ac
diff options
context:
space:
mode:
authorMarcus Meissner <marcus@jet.franken.de>2020-08-20 11:25:04 +0200
committerMarcus Meissner <marcus@jet.franken.de>2020-08-20 11:25:35 +0200
commit4e68fa7d2e7a399fe996b71f44c7b4b3c7753be1 (patch)
tree32721d957224420175c0138d1c498a84e9113884 /libgphoto2_port/configure.ac
parent6f32036fea1e41e91b894a1190ddabcbd65c3251 (diff)
downloadlibgphoto2-4e68fa7d2e7a399fe996b71f44c7b4b3c7753be1.tar.gz
usbscsi and usbdiskdirect are only working on Linux due to lowlevel
ioctl used. fixes https://github.com/gphoto/libgphoto2/issues/553
Diffstat (limited to 'libgphoto2_port/configure.ac')
-rw-r--r--libgphoto2_port/configure.ac15
1 files changed, 11 insertions, 4 deletions
diff --git a/libgphoto2_port/configure.ac b/libgphoto2_port/configure.ac
index a8546aa36..c9ab924b7 100644
--- a/libgphoto2_port/configure.ac
+++ b/libgphoto2_port/configure.ac
@@ -376,11 +376,11 @@ GP_CONFIG_MSG([USB ports])
GP_CHECK_LIBRARY([LIBUSB1],[libusb-1.0],[>= 1.0.0],
[libusb.h],[libusb_init],[
case "$host" in
- *-*-mingw* | *-*-cygwin* | *-*-msvc* )
- IOLIB_LIST="$IOLIB_LIST usb1"
+ *-linux*)
+ IOLIB_LIST="$IOLIB_LIST usb1 usbdiskdirect usbscsi"
;;
*)
- IOLIB_LIST="$IOLIB_LIST usb1 usbdiskdirect usbscsi"
+ IOLIB_LIST="$IOLIB_LIST usb1"
;;
esac
@@ -405,13 +405,20 @@ GP_CHECK_LIBRARY([LIBUSB],[libusb],[>= 0.1.5],
dnl Windows itself has usb.h we mis-detect, in that case remove access to the other usb.h
IOLIB_LIST="$IOLIB_LIST usb"
;;
- *)
+ *-linux*)
if test "x$have_LIBUSB1" != xyes; then
IOLIB_LIST="$IOLIB_LIST usb usbdiskdirect usbscsi"
else
GP_CONFIG_MSG([libusb0 support],[detected, but disabled (libusb1 support is enabled)])
fi
;;
+ *)
+ if test "x$have_LIBUSB1" != xyes; then
+ IOLIB_LIST="$IOLIB_LIST usb"
+ else
+ GP_CONFIG_MSG([libusb0 support],[detected, but disabled (libusb1 support is enabled)])
+ fi
+ ;;
esac
],[],
[default-on],