summaryrefslogtreecommitdiff
path: root/libgphoto2_port/configure.ac
diff options
context:
space:
mode:
authorMarcus Meissner <marcus@jet.franken.de>2015-04-06 21:08:06 +0000
committerMarcus Meissner <marcus@jet.franken.de>2015-04-06 21:08:06 +0000
commite0ad4f6f77a18b0919c80785102b79b3e8151866 (patch)
tree19d51ba294c8dc65a9731b2e85fa63c8fef136c8 /libgphoto2_port/configure.ac
parent41ef083e2268176cd8ad2e9ae9080c534587aaae (diff)
downloadlibgphoto2-e0ad4f6f77a18b0919c80785102b79b3e8151866.tar.gz
fixed libusb1 detection on debian-kfreebsd
git-svn-id: https://svn.code.sf.net/p/gphoto/code/trunk/libgphoto2@15418 67ed7778-7388-44ab-90cf-0a291f65f57c
Diffstat (limited to 'libgphoto2_port/configure.ac')
-rw-r--r--libgphoto2_port/configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/libgphoto2_port/configure.ac b/libgphoto2_port/configure.ac
index 781770691..6c32610ab 100644
--- a/libgphoto2_port/configure.ac
+++ b/libgphoto2_port/configure.ac
@@ -364,9 +364,13 @@ GP_CHECK_LIBRARY([LIBUSB1],[libusb-1.0],[>= 1.0.0],
esac
# only in libusbx? but not in traditional libusb 1.0
- AC_CHECK_LIB(usb-1.0,libusb_strerror, [
+ # note that the library is not always named libusb-1.0.so , e.g. on freebsd it is not.
+ save_LIBS="$LIBS"
+ LIBS="$LIBS $LIBUSB1_LIBS"
+ AC_CHECK_FUNC(libusb_strerror, [
AC_DEFINE(HAVE_LIBUSB_STRERROR,1,[Define if libusb-1.0 has libusb_strerror])
-])
+ ])
+ LIBS="$save_LIBS"
],[],
[default-on],