summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorMarcus Meissner <marcus@jet.franken.de>2014-02-26 07:07:09 +0000
committerMarcus Meissner <marcus@jet.franken.de>2014-02-26 07:07:09 +0000
commitac04ac3bf40ba69e165ef0fcd8d7ab2dca7b1a6d (patch)
tree325f171b07a878ca55e1543cb9ed02b43443adf4 /tests/Makefile.am
parente7373010129b3b87cc395f5fde2e6bad53403270 (diff)
downloadlibgphoto2-ac04ac3bf40ba69e165ef0fcd8d7ab2dca7b1a6d.tar.gz
added a test-endian to check our endianess macros
git-svn-id: https://svn.code.sf.net/p/gphoto/code/trunk/libgphoto2@14797 67ed7778-7388-44ab-90cf-0a291f65f57c
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 9896c937e..1358d20a1 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -24,6 +24,15 @@ AM_CPPFLAGS += -I$(top_srcdir) -I$(top_builddir) -I$(top_srcdir)/libgphoto2_por
CLEANFILES = $(check_SCRIPTS)
+noinst_PROGRAMS += test-endian
+test_endian_SOURCE = test-endian.c
+test_endian_LDADD = \
+ $(top_builddir)/libgphoto2/libgphoto2.la \
+ $(top_builddir)/libgphoto2_port/libgphoto2_port/libgphoto2_port.la \
+ $(LIBLTDL) \
+ $(LIBEXIF_LIBS) \
+ $(INTLLIBS)
+
noinst_PROGRAMS += test-gphoto2
test_gphoto2_SOURCE = test-gphoto2.c
test_gphoto2_LDADD = \