summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorHans Ulrich Niedermann <hun@n-dimensional.de>2021-10-15 06:49:48 +0200
committerHans Ulrich Niedermann <hun@n-dimensional.de>2021-12-12 16:35:48 +0100
commitd65a7211d47a18a6a8533ebe524e0f69d5d12de1 (patch)
tree9c86f8aeca73166d497a23e9fba91fb1b48caaec /tests/Makefile.am
parent397ae74674698122b4696ac897e70de439a2d0c9 (diff)
downloadlibgphoto2-d65a7211d47a18a6a8533ebe524e0f69d5d12de1.tar.gz
Add test-i18n.c i18n test program
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index fd6b6fc04..5eef508a8 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -33,6 +33,14 @@ INSTALL_TESTS_ENVIRONMENT = env \
AM_CPPFLAGS += -I$(top_srcdir) -I$(top_builddir) -I$(top_srcdir)/libgphoto2_port
+# Test i18n
+check_PROGRAMS += test-i18n
+test_i18n_SOURCES = test-i18n.c
+test_i18n_CPPFLAGS = $(AM_CPPFLAGS)
+test_i18n_CFLAGS = $(AM_CFLAGS)
+test_i18n_LDADD = $(INTLLIBS)
+
+
# Test endianness conversions
TESTS += test-endian
check_PROGRAMS += test-endian