summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index f7a42fb87..92668b96c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -13,9 +13,10 @@ SUBDIRS = . @subdirs@ libgphoto2 camlibs tests po bindings packaging doc
doc_DATA = AUTHORS COPYING README CHANGES NEWS
# Remove obsolete directory of copied/symlinked header files
+all-local:
+ if test -d gphoto2; then rm -f gphoto2/gphoto2*.h; rmdir gphoto2; fi
clean-local:
- rm -f gphoto2/gphoto2*.h
- rmdir gphoto2 || true
+ if test -d gphoto2; then rm -f gphoto2/gphoto2*.h; rmdir gphoto2; fi
# we use just ONE .PHONY target in order not to confuse automake