summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am150
1 files changed, 75 insertions, 75 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 5933f72ee..fdeb533be 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -95,118 +95,118 @@ test_camera_list_LDADD = \
# Test pedantic compilation for multiple language standard
########################################################################
-generic_pedantic_cppflags =
-generic_pedantic_cppflags += -I$(top_srcdir)/libgphoto2_port
-generic_pedantic_cppflags += -I$(top_srcdir)
+generic_pedantic_cppflags =
+generic_pedantic_cppflags += -I$(top_srcdir)/libgphoto2_port
+generic_pedantic_cppflags += -I$(top_srcdir)
if GP_HAVE_PEDANTIC_FLAGS_C90
-TESTS += test-pedantic-c90
-check_PROGRAMS += test-pedantic-c90
+TESTS += test-pedantic-c90
+check_PROGRAMS += test-pedantic-c90
endif
-EXTRA_PROGRAMS += test-pedantic-c90
-test_pedantic_c90_SOURCES = test-pedantic-compilation.c
-test_pedantic_c90_CPPFLAGS = $(generic_pedantic_cppflags)
-test_pedantic_c90_CFLAGS = $(GP_PEDANTIC_CFLAGS_C90)
-test_pedantic_c90_LDADD =
-test_pedantic_c90_LDFLAGS =
+EXTRA_PROGRAMS += test-pedantic-c90
+test_pedantic_c90_SOURCES = test-pedantic-compilation.c
+test_pedantic_c90_CPPFLAGS = $(generic_pedantic_cppflags)
+test_pedantic_c90_CFLAGS = $(GP_PEDANTIC_CFLAGS_C90)
+test_pedantic_c90_LDADD =
+test_pedantic_c90_LDFLAGS =
if GP_HAVE_PEDANTIC_FLAGS_C99
-TESTS += test-pedantic-c99
-check_PROGRAMS += test-pedantic-c99
+TESTS += test-pedantic-c99
+check_PROGRAMS += test-pedantic-c99
endif
-EXTRA_PROGRAMS += test-pedantic-c99
-test_pedantic_c99_SOURCES = test-pedantic-compilation.c
-test_pedantic_c99_CPPFLAGS = $(generic_pedantic_cppflags)
-test_pedantic_c99_CFLAGS = $(GP_PEDANTIC_CFLAGS_C99)
-test_pedantic_c99_LDADD =
-test_pedantic_c99_LDFLAGS =
+EXTRA_PROGRAMS += test-pedantic-c99
+test_pedantic_c99_SOURCES = test-pedantic-compilation.c
+test_pedantic_c99_CPPFLAGS = $(generic_pedantic_cppflags)
+test_pedantic_c99_CFLAGS = $(GP_PEDANTIC_CFLAGS_C99)
+test_pedantic_c99_LDADD =
+test_pedantic_c99_LDFLAGS =
if GP_HAVE_PEDANTIC_FLAGS_C11
-TESTS += test-pedantic-c11
-check_PROGRAMS += test-pedantic-c11
+TESTS += test-pedantic-c11
+check_PROGRAMS += test-pedantic-c11
endif
-EXTRA_PROGRAMS += test-pedantic-c11
-test_pedantic_c11_SOURCES = test-pedantic-compilation.c
-test_pedantic_c11_CPPFLAGS = $(generic_pedantic_cppflags)
-test_pedantic_c11_CFLAGS = $(GP_PEDANTIC_CFLAGS_C11)
-test_pedantic_c11_LDADD =
-test_pedantic_c11_LDFLAGS =
+EXTRA_PROGRAMS += test-pedantic-c11
+test_pedantic_c11_SOURCES = test-pedantic-compilation.c
+test_pedantic_c11_CPPFLAGS = $(generic_pedantic_cppflags)
+test_pedantic_c11_CFLAGS = $(GP_PEDANTIC_CFLAGS_C11)
+test_pedantic_c11_LDADD =
+test_pedantic_c11_LDFLAGS =
if GP_HAVE_PEDANTIC_FLAGS_C2X
-TESTS += test-pedantic-c2x
-check_PROGRAMS += test-pedantic-c2x
+TESTS += test-pedantic-c2x
+check_PROGRAMS += test-pedantic-c2x
endif
-EXTRA_PROGRAMS += test-pedantic-c2x
-test_pedantic_c2x_SOURCES = test-pedantic-compilation.c
-test_pedantic_c2x_CPPFLAGS = $(generic_pedantic_cppflags)
-test_pedantic_c2x_CFLAGS = $(GP_PEDANTIC_CFLAGS_C2X)
-test_pedantic_c2x_LDADD =
-test_pedantic_c2x_LDFLAGS =
+EXTRA_PROGRAMS += test-pedantic-c2x
+test_pedantic_c2x_SOURCES = test-pedantic-compilation.c
+test_pedantic_c2x_CPPFLAGS = $(generic_pedantic_cppflags)
+test_pedantic_c2x_CFLAGS = $(GP_PEDANTIC_CFLAGS_C2X)
+test_pedantic_c2x_LDADD =
+test_pedantic_c2x_LDFLAGS =
if HAVE_CXX
if GP_HAVE_PEDANTIC_FLAGS_CXX98
-TESTS += test-pedantic-cxx98
-check_PROGRAMS += test-pedantic-cxx98
+TESTS += test-pedantic-cxx98
+check_PROGRAMS += test-pedantic-cxx98
endif
endif
-EXTRA_PROGRAMS += test-pedantic-cxx98
-test_pedantic_cxx98_SOURCES = test-pedantic-compilation.cxx
-test_pedantic_cxx98_CPPFLAGS = $(generic_pedantic_cppflags)
-test_pedantic_cxx98_CXXFLAGS = $(GP_PEDANTIC_CXXFLAGS_CXX98)
-test_pedantic_cxx98_LDADD =
-test_pedantic_cxx98_LDFLAGS =
+EXTRA_PROGRAMS += test-pedantic-cxx98
+test_pedantic_cxx98_SOURCES = test-pedantic-compilation.cxx
+test_pedantic_cxx98_CPPFLAGS = $(generic_pedantic_cppflags)
+test_pedantic_cxx98_CXXFLAGS = $(GP_PEDANTIC_CXXFLAGS_CXX98)
+test_pedantic_cxx98_LDADD =
+test_pedantic_cxx98_LDFLAGS =
if HAVE_CXX
if GP_HAVE_PEDANTIC_FLAGS_CXX11
-TESTS += test-pedantic-cxx11
-check_PROGRAMS += test-pedantic-cxx11
+TESTS += test-pedantic-cxx11
+check_PROGRAMS += test-pedantic-cxx11
endif
endif
-EXTRA_PROGRAMS += test-pedantic-cxx11
-test_pedantic_cxx11_SOURCES = test-pedantic-compilation.cxx
-test_pedantic_cxx11_CPPFLAGS = $(generic_pedantic_cppflags)
-test_pedantic_cxx11_CXXFLAGS = $(GP_PEDANTIC_CXXFLAGS_CXX11)
-test_pedantic_cxx11_LDADD =
-test_pedantic_cxx11_LDFLAGS =
+EXTRA_PROGRAMS += test-pedantic-cxx11
+test_pedantic_cxx11_SOURCES = test-pedantic-compilation.cxx
+test_pedantic_cxx11_CPPFLAGS = $(generic_pedantic_cppflags)
+test_pedantic_cxx11_CXXFLAGS = $(GP_PEDANTIC_CXXFLAGS_CXX11)
+test_pedantic_cxx11_LDADD =
+test_pedantic_cxx11_LDFLAGS =
if HAVE_CXX
if GP_HAVE_PEDANTIC_FLAGS_CXX14
-TESTS += test-pedantic-cxx14
-check_PROGRAMS += test-pedantic-cxx14
+TESTS += test-pedantic-cxx14
+check_PROGRAMS += test-pedantic-cxx14
endif
endif
-EXTRA_PROGRAMS += test-pedantic-cxx14
-test_pedantic_cxx14_SOURCES = test-pedantic-compilation.cxx
-test_pedantic_cxx14_CPPFLAGS = $(generic_pedantic_cppflags)
-test_pedantic_cxx14_CXXFLAGS = $(GP_PEDANTIC_CXXFLAGS_CXX14)
-test_pedantic_cxx14_LDADD =
-test_pedantic_cxx14_LDFLAGS =
+EXTRA_PROGRAMS += test-pedantic-cxx14
+test_pedantic_cxx14_SOURCES = test-pedantic-compilation.cxx
+test_pedantic_cxx14_CPPFLAGS = $(generic_pedantic_cppflags)
+test_pedantic_cxx14_CXXFLAGS = $(GP_PEDANTIC_CXXFLAGS_CXX14)
+test_pedantic_cxx14_LDADD =
+test_pedantic_cxx14_LDFLAGS =
if HAVE_CXX
if GP_HAVE_PEDANTIC_FLAGS_CXX17
-TESTS += test-pedantic-cxx17
-check_PROGRAMS += test-pedantic-cxx17
+TESTS += test-pedantic-cxx17
+check_PROGRAMS += test-pedantic-cxx17
endif
endif
-EXTRA_PROGRAMS += test-pedantic-cxx17
-test_pedantic_cxx17_SOURCES = test-pedantic-compilation.cxx
-test_pedantic_cxx17_CPPFLAGS = $(generic_pedantic_cppflags)
-test_pedantic_cxx17_CXXFLAGS = $(GP_PEDANTIC_CXXFLAGS_CXX17)
-test_pedantic_cxx17_LDADD =
-test_pedantic_cxx17_LDFLAGS =
+EXTRA_PROGRAMS += test-pedantic-cxx17
+test_pedantic_cxx17_SOURCES = test-pedantic-compilation.cxx
+test_pedantic_cxx17_CPPFLAGS = $(generic_pedantic_cppflags)
+test_pedantic_cxx17_CXXFLAGS = $(GP_PEDANTIC_CXXFLAGS_CXX17)
+test_pedantic_cxx17_LDADD =
+test_pedantic_cxx17_LDFLAGS =
if HAVE_CXX
if GP_HAVE_PEDANTIC_FLAGS_CXX20
-TESTS += test-pedantic-cxx20
-check_PROGRAMS += test-pedantic-cxx20
+TESTS += test-pedantic-cxx20
+check_PROGRAMS += test-pedantic-cxx20
endif
endif
-EXTRA_PROGRAMS += test-pedantic-cxx20
-test_pedantic_cxx20_SOURCES = test-pedantic-compilation.cxx
-test_pedantic_cxx20_CPPFLAGS = $(generic_pedantic_cppflags)
-test_pedantic_cxx20_CXXFLAGS = $(GP_PEDANTIC_CXXFLAGS_CXX20)
-test_pedantic_cxx20_LDADD =
-test_pedantic_cxx20_LDFLAGS =
+EXTRA_PROGRAMS += test-pedantic-cxx20
+test_pedantic_cxx20_SOURCES = test-pedantic-compilation.cxx
+test_pedantic_cxx20_CPPFLAGS = $(generic_pedantic_cppflags)
+test_pedantic_cxx20_CXXFLAGS = $(GP_PEDANTIC_CXXFLAGS_CXX20)
+test_pedantic_cxx20_LDADD =
+test_pedantic_cxx20_LDFLAGS =
########################################################################