summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am18
1 files changed, 12 insertions, 6 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 8ea93c4d7..20da5eaa8 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -14,8 +14,10 @@ check_SCRIPTS = \
EXTRA_DIST = \
check-camera-list.sh.in
-# TESTS = $(check_SCRIPTS)
+TESTS = test-pedantic-c test-pedantic-cxx
+# These tests must run after installation because they need the
+# camlibs installed.
INSTALL_TESTS = check-camera-list.sh
CLEANFILES = $(check_SCRIPTS)
@@ -47,7 +49,7 @@ test_camera_list_LDADD = \
if HAVE_GCC
PEDANTIC_CFLAGS = -std=c99 -pedantic-errors -W -Wall -Wextra -Werror
-PEDANTIC_CXXFLAGS = -ansi -pedantic-errors -W -Wall -Wextra -Werror
+PEDANTIC_CXXFLAGS = -std=c++98 -pedantic-errors -W -Wall -Wextra -Werror
else
PEDANTIC_CFLAGS =
PEDANTIC_CXXFLAGS =
@@ -56,8 +58,10 @@ endif
test_pedantic_c_SOURCES = test-pedantic-compilation.c
test_pedantic_c_CPPFLAGS = \
$(AM_CPPFLAGS) $(CPPFLAGS) \
- -U _GPHOTO2_INTERNAL_CODE
-test_pedantic_c_CFLAGS = $(PEDANTIC_CFLAGS) $(AM_CFLAGS) $(CFLAGS)
+ -U_GPHOTO2_INTERNAL_CODE
+test_pedantic_c_CFLAGS = \
+ $(PEDANTIC_CFLAGS) $(AM_CFLAGS) $(CFLAGS) \
+ -U_GPHOTO2_INTERNAL_CODE
test_pedantic_c_LDADD = \
$(top_builddir)/libgphoto2/libgphoto2.la \
$(top_builddir)/libgphoto2_port/libgphoto2_port/libgphoto2_port.la \
@@ -67,8 +71,10 @@ test_pedantic_c_LDADD = \
test_pedantic_cxx_SOURCES = test-pedantic-compilation.cxx
test_pedantic_cxx_CPPFLAGS = \
$(AM_CPPFLAGS) $(CPPFLAGS) \
- -U _GPHOTO2_INTERNAL_CODE
-test_pedantic_cxx_CXXFLAGS = $(PEDANTIC_CXXFLAGS) $(AM_CXXFLAGS) $(CXXFLAGS)
+ -U_GPHOTO2_INTERNAL_CODE
+test_pedantic_cxx_CXXFLAGS = \
+ $(PEDANTIC_CXXFLAGS) $(AM_CXXFLAGS) $(CXXFLAGS) \
+ -U_GPHOTO2_INTERNAL_CODE
test_pedantic_cxx_LDADD = \
$(top_builddir)/libgphoto2/libgphoto2.la \
$(top_builddir)/libgphoto2_port/libgphoto2_port/libgphoto2_port.la \