summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorColin Walters <walters@verbum.org>2015-02-15 14:11:58 -0500
committerColin Walters <walters@verbum.org>2015-02-15 14:11:58 -0500
commit16862cc4d4e38493705386cf26e2eb46063809ea (patch)
tree77212c71f5ff0510dc5125eeea310f0b99901087 /Makefile.am
parent6f5b70922ee1f329c24b8a74f61be4f4c0c946ef (diff)
downloadlibgsystem-16862cc4d4e38493705386cf26e2eb46063809ea.tar.gz
Start using libglnx
We can pull in libglnx here, and have this module become a GFile * wrapper plus legacy code.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 74bbbdf..6a76e9f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -31,5 +31,11 @@ if BUILDOPT_INTROSPECTION
include $(INTROSPECTION_MAKEFILE)
endif
+libglnx_srcpath := $(srcdir)/libglnx
+libglnx_cflags := $(BUILDDEP_GIO_UNIX_CFLAGS) -I$(libglnx_srcpath)
+libglnx_libs := $(BUILDDEP_GIO_UNIX_LIBS)
+
+noinst_LTLIBRARIES += libglnx.la
+include libglnx/Makefile-libglnx.am
include Makefile-libgsystem.am
include Makefile-tests.am