summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorColin Walters <walters@verbum.org>2014-02-05 06:58:51 -0500
committerColin Walters <walters@verbum.org>2014-02-06 04:12:18 -0500
commit9363cfc28ede912e2f06d4ccb42a646bb8a4bd2e (patch)
tree94d03e2391e4cdee87a8345013e3ac5b6e21cef4 /Makefile.am
parent856b8f9431a63c7807fb3859ed6de2a0f3abfb3b (diff)
downloadlibgsystem-9363cfc28ede912e2f06d4ccb42a646bb8a4bd2e.tar.gz
Rework to be an installed libraryv2014.1
See https://mail.gnome.org/archives/desktop-devel-list/2014-February/msg00028.html
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..472fbc1
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,34 @@
+# Copyright (C) 2011,2014 Colin Walters <walters@verbum.org>
+#
+# This library is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Lesser General Public
+# License as published by the Free Software Foundation; either
+# version 2 of the License, or (at your option) any later version.
+#
+# This library is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Lesser General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with this library; if not, write to the
+# Free Software Foundation, Inc., 59 Temple Place - Suite 330,
+# Boston, MA 02111-1307, USA.
+
+include Makefile-decls.am
+
+ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
+AM_CPPFLAGS += -DDATADIR='"$(datadir)"' -DLIBEXECDIR='"$(libexecdir)"' \
+ -DGLIB_VERSION_MIN_REQUIRED=GLIB_VERSION_2_34 -DGLIB_VERSION_MAX_ALLOWED=GLIB_VERSION_2_34
+AM_CFLAGS += $(WARN_CFLAGS)
+DISTCHECK_CONFIGURE_FLAGS += --enable-gtk-doc --disable-maintainer-mode
+
+SUBDIRS += .
+
+EXTRA_DIST += autogen.sh COPYING README
+
+if BUILDOPT_INTROSPECTION
+include $(INTROSPECTION_MAKEFILE)
+endif
+
+include Makefile-libgsystem.am