summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorChoe Hwanjin <choe.hwanjin@gmail.com>2008-11-11 22:47:54 +0900
committerChoe Hwanjin <choe.hwanjin@gmail.com>2008-11-11 22:47:54 +0900
commita75baba1e8e86aa5148c87fde2391dbde1a5a4b3 (patch)
tree69439f29ac3794ff36d3771f0e6097e510578ae9 /Makefile.am
parentd2333867c8d89a6336dbd7d7f2ef3df297cca7d6 (diff)
downloadlibhangul-a75baba1e8e86aa5148c87fde2391dbde1a5a4b3.tar.gz
한자 데이터를 관리하는 HanjaTable의 작동 방식을 개선:
* 기존에 한자 데이터를 binary로 변환하여 로딩하던 코드를 제거 * text 파일에 대한 index만 가지고 있으면서 요청시에 매번 파일을 읽어서 데이터를 리턴하는 방식으로 구현함 * 예전 방식은 메모리를 많이 차지하여 사용하지 않음 * 파일에서 매번 읽는 방식도 그리 속도가 나쁘지 않으므로 사용하기로 하였음 * hanja.txt 를 바이너리 포맷으로 변환하던 툴 제거 * hanja.bin 대신 hanja.txt 파일을 설치 * 참조: http://lists.kldp.net/pipermail/hangul-hackers/2008-November/000385.html git-svn-id: http://kldp.net/svn/hangul/libhangul/trunk@188 8f00fcd2-89fc-0310-932e-b01be5b65e01
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 65cfd6f..d63f35e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,4 +1,4 @@
-SUBDIRS = hangul tools data test
+SUBDIRS = hangul data test
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = libhangul.pc