summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChoe Hwanjin <choe.hwanjin@gmail.com>2004-11-08 20:39:11 +0900
committerChoe Hwanjin <choe.hwanjin@gmail.com>2004-11-08 20:39:11 +0900
commit0e0b2886d127cfe94b29c8ace8f7c70b6846223a (patch)
tree8a3ab443162f08d913b535fde27a74f619dc4fd7 /configure.ac
downloadlibhangul-0e0b2886d127cfe94b29c8ace8f7c70b6846223a.tar.gz
Initial revision
git-svn-id: http://kldp.net/svn/hangul/trunk/hangul@3 8f00fcd2-89fc-0310-932e-b01be5b65e01
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 30 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..8cf0191
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,30 @@
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ(2.57)
+AC_INIT(libhangul, 0.0.1, http://kldp.net/projects/hangul/)
+AM_INIT_AUTOMAKE
+AC_CONFIG_SRCDIR([hangul/hangul.h])
+AC_CONFIG_HEADER([config.h])
+
+# Checks for programs.
+AC_PROG_CC
+AC_PROG_RANLIB
+
+# Checks for libraries.
+
+# Checks for header files.
+AC_CHECK_HEADERS([locale.h stdint.h stdlib.h string.h wchar.h])
+
+# Checks for typedefs, structures, and compiler characteristics.
+AC_HEADER_STDBOOL
+AC_C_CONST
+AC_C_INLINE
+
+# Checks for library functions.
+AC_CONFIG_FILES([
+Makefile
+hangul/Makefile
+test/Makefile
+])
+AC_OUTPUT