summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChoe Hwanjin <choe.hwanjin@gmail.com>2008-02-24 02:29:23 +0900
committerChoe Hwanjin <choe.hwanjin@gmail.com>2008-02-24 02:29:23 +0900
commit234795cf54ad7ab9376d204720e4f9ab3a851e99 (patch)
tree0b82311c352f21391928882d7c2d16af03ba61d4 /configure.ac
parentebb1debbbac572af8e0655b2071185e138ead403 (diff)
downloadlibhangul-234795cf54ad7ab9376d204720e4f9ab3a851e99.tar.gz
한자 사전 파일을 바이너리 형태로 사용하는 기능 구현:
* 내부적으로 mmap을 이용하여 로딩, 메모리 사용량을 줄임 * txt 버젼은 vector로 구현, 더이상 slist를 사용하지 않음 * hanja.txt파일을 hanja.bin 형태로 변환하여 사용함 * 파일 포맷 변환을 위한 API, hanja_table_txt_to_bin() 추가 * tools 디렉토리 추가 * 파일 포맷 변환을 위해 hanjac라는 도구를 제공 * 기본 한자 사전 파일을 hanja.txt에서 hanja.bin으로 변경 새로운 api 추가 * hanja_list_get_nth_key() git-svn-id: http://kldp.net/svn/hangul/libhangul/trunk@158 8f00fcd2-89fc-0310-932e-b01be5b65e01
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ef28e77..f43e1f0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -26,7 +26,7 @@ AC_PROG_INSTALL
# Checks for header files.
AC_HEADER_STDC
-AC_CHECK_HEADERS([stdlib.h string.h])
+AC_CHECK_HEADERS([stdlib.h string.h limits.h])
# Checks for typedefs, structures, and compiler characteristics.
AC_HEADER_STDBOOL
@@ -36,9 +36,17 @@ AC_C_INLINE
AC_TYPE_UINT32_T
# Checks for library functions.
+AC_FUNC_MEMCMP
+AC_FUNC_MMAP
+AC_FUNC_REALLOC
+AC_CHECK_FUNCS([munmap])
+AC_CHECK_FUNCS([strcasecmp])
+
+
AC_CONFIG_FILES([
Makefile
hangul/Makefile
+tools/Makefile
data/Makefile
data/hanja/Makefile
bindings/Makefile