summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2307e55..8adbdb8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -35,6 +35,11 @@ option(ENABLE_EXTERNAL_KEYBOARDS
ON
)
+option(ENABLE_UNIT_TEST
+ "Enable/Disable unit test."
+ ON
+)
+
include(CTest)
include(GNUInstallDirs)
@@ -48,7 +53,7 @@ add_subdirectory(tools)
add_subdirectory(po)
if(BUILD_TESTING)
- add_subdirectory(test)
+ add_subdirectory(test EXCLUDE_FROM_ALL)
endif()
include(CMakePackageConfigHelpers)