summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Winter <allen.winter@kdab.com>2022-06-01 19:17:09 -0400
committerAllen Winter <allen.winter@kdab.com>2022-06-01 19:17:09 -0400
commit03b1648a3babe2a7cb51bb5cb18c9edc825f7f5a (patch)
tree75a7c509887c6158de39375e2d4ebf1ddda7c1e1 /CMakeLists.txt
parentacf22732a262139e1710330bb102bb7fe54c3fe1 (diff)
downloadlibical-git-03b1648a3babe2a7cb51bb5cb18c9edc825f7f5a.tar.gz
CMakeLists.txt - fix line continuations
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt26
1 files changed, 13 insertions, 13 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f8929603..f88bf312 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -369,9 +369,9 @@ else()
set(DEF_USE_BUILTIN_TZDATA False)
endif()
libical_option(USE_BUILTIN_TZDATA
- "(Careful) Build using libical's built-in timezone data, else use the system timezone data on non-Windows systems. "
- "ALWAYS true on Windows. Non-Windows users should know what they're doing if they choose not to use system provided "
- "timezone data. The libical project does not guarantee that the built-in timezone data is up-to-date."
+ "(Careful) Build using libical's built-in timezone data, else use the system timezone data on non-Windows systems. \
+ ALWAYS true on Windows. Non-Windows users should know what they're doing if they choose not to use system provided \
+ timezone data. The libical project does not guarantee that the built-in timezone data is up-to-date."
${DEF_USE_BUILTIN_TZDATA}
)
mark_as_advanced(USE_BUILTIN_TZDATA)
@@ -407,8 +407,8 @@ find_package(PkgConfig QUIET)
set(MIN_GOBJECT_INTROSPECTION "0.6.7")
libical_option(GOBJECT_INTROSPECTION
- "Build GObject introspection \"typelib\" files. "
- "Requires GObject Introspection development package ${MIN_GOBJECT_INTROSPECTION} or higher."
+ "Build GObject introspection \"typelib\" files. \
+ Requires GObject Introspection development package ${MIN_GOBJECT_INTROSPECTION} or higher."
False
)
if(GOBJECT_INTROSPECTION)
@@ -477,8 +477,8 @@ endif()
set(MIN_GLIB "2.44")
set(MIN_LIBXML "2.7.3")
libical_option(ICAL_GLIB
- "Build libical-glib interface. "
- "Requires glib ${MIN_GLIB} and libxml ${MIN_LIBXML} development packages or higher."
+ "Build libical-glib interface. \
+ Requires glib ${MIN_GLIB} and libxml ${MIN_LIBXML} development packages or higher."
True
)
if(ICAL_GLIB)
@@ -536,9 +536,9 @@ if(DEFINED CMAKE_C_COMPILER_ID)
endif()
if(CMAKE_C_COMPILER_IS_GCC OR CMAKE_C_COMPILER_IS_CLANG)
set(CMAKE_C_FLAGS
- "${CMAKE_C_FLAGS} -fvisibility=hidden "
- "-Wno-deprecated -Wall -Wno-unknown-pragmas -Wextra -Winit-self -Wunused -Wno-div-by-zero "
- "-Wundef -Wpointer-arith -Wtype-limits -Wwrite-strings -Werror=return-type"
+ "${CMAKE_C_FLAGS} -fvisibility=hidden \
+ -Wno-deprecated -Wall -Wno-unknown-pragmas -Wextra -Winit-self -Wunused -Wno-div-by-zero \
+ -Wundef -Wpointer-arith -Wtype-limits -Wwrite-strings -Werror=return-type"
)
libical_add_cflag(-Wunused-but-set-variable UNUSED_BUT_SET)
libical_add_cflag(-Wlogical-op LOGICAL_OP)
@@ -564,9 +564,9 @@ if(DEFINED CMAKE_CXX_COMPILER_ID)
endif()
if(CMAKE_CXX_COMPILER_IS_GCC OR CMAKE_CXX_COMPILER_IS_CLANG)
set(CMAKE_CXX_FLAGS
- "${CMAKE_CXX_FLAGS} -fvisibility=hidden "
- "-Weffc++ -Wno-deprecated -Wall -Wextra -Woverloaded-virtual -Winit-self -Wunused "
- "-Wno-div-by-zero -Wundef -Wpointer-arith -Wtype-limits -Wwrite-strings -Werror=return-type"
+ "${CMAKE_CXX_FLAGS} -fvisibility=hidden \
+ -Weffc++ -Wno-deprecated -Wall -Wextra -Woverloaded-virtual -Winit-self -Wunused \
+ -Wno-div-by-zero -Wundef -Wpointer-arith -Wtype-limits -Wwrite-strings -Werror=return-type"
)
libical_add_cxxflag(-Wunused-but-set-variable UNUSED_BUT_SET)
libical_add_cxxflag(-Wlogical-op LOGICAL_OP)