summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Winter <allen.winter@kdab.com>2022-11-13 12:37:26 -0500
committerAllen Winter <allen.winter@kdab.com>2022-11-13 12:37:26 -0500
commit04b59f04981078f24a42f2c57db928c1a8e2284e (patch)
tree2211025d6a95e9104034afaa5afe5dca11554967 /CMakeLists.txt
parent36e97ead47581fd78a99cafe3d0bed0bf90f39c1 (diff)
parentca294b8305196e5c857ed34a797e6ba47e338acc (diff)
downloadlibical-git-04b59f04981078f24a42f2c57db928c1a8e2284e.tar.gz
Merge branch '3.0'
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9994db09..09e37fc3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -581,6 +581,8 @@ endif()
if(CMAKE_C_COMPILER_IS_CLANG)
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Qunused-arguments")
endif()
+set(CMAKE_C_STANDARD 99)
+set(CMAKE_C_STANDARD_REQUIRED ON)
set(CMAKE_CXX_COMPILER_IS_CLANG False)
set(CMAKE_CXX_COMPILER_IS_GCC False)
@@ -612,6 +614,8 @@ endif()
if(CMAKE_CXX_COMPILER_IS_CLANG)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Qunused-arguments")
endif()
+set(CMAKE_CXX_STANDARD 11)
+set(CMAKE_CXX_STANDARD_REQUIRED ON)
#some test programs need to know if we are using 32-bit time
if(SIZEOF_TIME_T EQUAL 4)