summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Winter <allen.winter@kdab.com>2021-11-07 15:35:05 -0500
committerAllen Winter <allen.winter@kdab.com>2021-11-07 15:35:05 -0500
commit2605580b7f3aa6d24157bb4e3fdb4bc1d15e03d7 (patch)
tree3658352c0c9fd18f145eed5f90d925f11815015e /CMakeLists.txt
parent386a21c6d047adcc1b50a101e850f6b16541efcc (diff)
parente535a73fbabc46abf3d87e3245335ab66d00f432 (diff)
downloadlibical-git-2605580b7f3aa6d24157bb4e3fdb4bc1d15e03d7.tar.gz
Merge branch '3.0'
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 6 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ee3df5d7..ae1f08f6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -101,8 +101,11 @@ endif()
if(POLICY CMP0054)
cmake_policy(SET CMP0054 NEW)
endif()
+if(POLICY CMP0074)
+ cmake_policy(SET CMP0074 NEW) #don't warn about ICU_ROOT envvar
+endif()
-list(APPEND CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR}/cmake/modules)
+list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake/modules")
#Include CMake capabilities
include(LibIcalMacrosInternal)
@@ -241,9 +244,9 @@ if(ICU_FOUND)
get_filename_component(ICU_EXEC ${ICU_MAKECONV_EXECUTABLE} DIRECTORY)
else()
message(FATAL_ERROR
- "Unable find locate the ICU runtime path. Is your ICU installation broken?")
+ "Unable to locate the ICU runtime path. Is your ICU installation broken?")
endif()
- set(ICU_BINARY_DIR ${ICU_EXEC} CACHE DOC STRING "Runtime binaries directory for the ICU library")
+ set(ICU_BINARY_DIR ${ICU_EXEC} CACHE STRING DOC "Runtime binaries directory for the ICU library")
endif()
# compile in Berkeley DB support