summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Winter <allen.winter@kdab.com>2022-06-03 13:08:19 -0400
committerAllen Winter <allen.winter@kdab.com>2022-06-03 13:08:19 -0400
commit4f22bbb2d1d1f3a7a218e2d8d363f94a071151c9 (patch)
tree8befa5870b70aec86b3f5d1d481a470bd456063e /CMakeLists.txt
parent32c14b2e448199d0a9de91e9844ef32abf9e4747 (diff)
downloadlibical-git-4f22bbb2d1d1f3a7a218e2d8d363f94a071151c9.tar.gz
buildsystem - USE_64BIT_ICALTIME_T -> LIBICAL_ENABLE_64BIT_ICALTIME_T
namespace the cmake options
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt17
1 files changed, 12 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5a8ae773..bb8925e7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -66,8 +66,10 @@
# Set to build using a 32bit time_t (ignored unless building with MSVC on Windows)
# Default=false (use the default size of time_t)
#
-# -DUSE_64BIT_ICALTIME_T=[true|false]
-# Experimental: Redirect icaltime_t (and related functions) to a 64-bit version of time_t rather than to time_t.
+# -DLIBICAL_ENABLE_64BIT_ICALTIME_T=[true|false]
+# Redirect icaltime_t (and related functions) to a 64-bit version of time_t rather than to the
+# C standard library time_t. Intended for use on 32-bit systems which have a 64-bit time_t
+# (such as `__time64_t` on Windows) available.
# Default=false (use plain time_t)
#
# -DLIBICAL_BUILD_TESTING=[true|false]
@@ -330,13 +332,18 @@ if(WIN32)
endif()
# define icaltime_t
-libical_option(USE_64BIT_ICALTIME_T "Experimental: Redirect icaltime_t (and related functions) to a 64-bit version of time_t rather than to time_t." False)
-if(USE_64BIT_ICALTIME_T)
+libical_option(LIBICAL_ENABLE_64BIT_ICALTIME_T
+ "Redirect icaltime_t and related functions to a 64-bit version of time_t rather than to the \
+ C standard library time_t. Intended for use on 32-bit systems which have a 64-bit time_t available. \
+ May not be implemented on all platforms yet"
+ False
+)
+if(LIBICAL_ENABLE_64BIT_ICALTIME_T)
if(MSVC)
set(ICAL_ICALTIME_T_TYPE "__time64_t")
else()
message(FATAL_ERROR
- "Option USE_64BIT_ICALTIME_T is not supported with this compiler or architecture.")
+ "Option LIBICAL_ENABLE_64BIT_ICALTIME_T is not supported with this compiler or architecture.")
endif()
else()
set(ICAL_ICALTIME_T_TYPE "time_t")