summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Winter <allen.winter@kdab.com>2022-01-22 12:02:30 -0500
committerAllen Winter <allen.winter@kdab.com>2022-01-22 12:02:30 -0500
commit71d09589f291bc9b95974a4d4db4087121ed4bc9 (patch)
tree6dc37e780bc73dfa588d8e4a0226bf3242d3e153 /CMakeLists.txt
parentd30f2ba33befd89e4ead4be6552ebf79efd2a490 (diff)
downloadlibical-git-71d09589f291bc9b95974a4d4db4087121ed4bc9.tar.gz
make it more explicit that C99 compliance is necessary
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5b087a86..2d43e6fb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -281,6 +281,10 @@ if(BerkeleyDB_FOUND)
set(BDB_LIBRARY ${BerkeleyDB_LIBRARIES})
endif()
+# C99 compliant compiler is required
+set(CMAKE_C_STANDARD 99)
+set(CMAKE_C_STANDARD_REQUIRED ON)
+
# MSVC specific definitions
if(WIN32)
if(MSVC)