summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChristophe Giboudeaux <christophe@krop.fr>2018-08-21 17:02:27 +0200
committerChristophe Giboudeaux <christophe@krop.fr>2018-08-21 17:05:14 +0200
commit8e307744af2840b0ece1d74637f295f36083e426 (patch)
tree4dff17544b023fe1385ba6df23b8d1624e22c303 /CMakeLists.txt
parent4bbc31318bb97a7b32caf110f9c6d936ac81fa5c (diff)
downloadlibical-git-8e307744af2840b0ece1d74637f295f36083e426.tar.gz
Look for a CXX compiler if WITH_CXX_BINDINGS is true
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5bcda64a..02af38c4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -539,6 +539,7 @@ endif()
option(WITH_CXX_BINDINGS "Build the C++ bindings." True)
if(WITH_CXX_BINDINGS)
+ enable_language(CXX)
if(CMAKE_CXX_COMPILER)
add_definitions(-DWITH_CXX_BINDINGS)
else()