summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Winter <allen.winter@kdab.com>2017-06-03 17:01:10 -0400
committerAllen Winter <allen.winter@kdab.com>2017-06-03 17:01:10 -0400
commit910aa8066a26e192dfc6042fd40634bdb8d80c25 (patch)
tree3f4d1513d36dbd690da43a35f7e87839f7b5b040 /CMakeLists.txt
parent2a5d9b0b63863d036ee2519f69a4a917f7cfbdd7 (diff)
downloadlibical-git-910aa8066a26e192dfc6042fd40634bdb8d80c25.tar.gz
s/GObjectIntrospection/INTROSPECTION/g
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 61adad9c..baa22264 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -229,7 +229,12 @@ set(MIN_GOBJECT_INTROSPECTION "0.6.7")
option(GOBJECT_INTROSPECTION "Build GObject introspection \"typelib\" files. Requires GObject Introspection development package ${MIN_GOBJECT_INTROSPECTION} or higher.")
if(GOBJECT_INTROSPECTION)
find_package(GObjectIntrospection ${MIN_GOBJECT_INTROSPECTION})
- if(INTROSPECTION_FOUND)
+ set_package_properties(GObjectIntrospection PROPERTIES
+ TYPE REQUIRED
+ URL "https://wiki.gnome.org/Projects/GObjectIntrospection"
+ PURPOSE "Required in order to build the GObject introspection \"typelib\" files.\n (due to the -DGOBJECT_INTROSPECTION=True CMake option)"
+ )
+ if(GObjectIntrospection_FOUND)
set(HAVE_INTROSPECTION TRUE)
if(STATIC_ONLY)
message(FATAL_ERROR "You are attempting to build with GObject Introspection enabled, however that option is not supported when building static libraries only. Please disable the static only option to CMake (-DSTATIC_ONLY=False) if you really want to build with GObject Introspection. Alternatively, you can disable GObject Introspection (by passing -DGOBJECT_INTROSPECTION=False to CMake)")