summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Winter <allen.winter@kdab.com>2021-11-27 09:23:17 -0500
committerAllen Winter <allen.winter@kdab.com>2021-11-27 09:23:17 -0500
commit9cbfe94975e423a519af550b559ade35f28c4b02 (patch)
tree6ceed46459b079ca5c2342089d3952ce620d6c76 /CMakeLists.txt
parent7822c0e5f5fd1ef702d5159977badea56ae8e20c (diff)
parentca908f9971992dbc244381962a101238bd5dcead (diff)
downloadlibical-git-9cbfe94975e423a519af550b559ade35f28c4b02.tar.gz
Merge branch '3.0'
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1b06ea91..5fba305e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -25,7 +25,7 @@
#
# -DSTATIC_ONLY=[true|false]
# Set to build static libraries only.
-# Turns-off GObject Introspection.
+# Not available for GObject Introspection and Vala "vapi"
# Default=false (build shared and static libs)
#
# -DSHARED_ONLY=[true|false]
@@ -390,6 +390,14 @@ endif()
libical_option(ICAL_GLIB_VAPI "Build Vala \"vapi\" files." False)
if(ICAL_GLIB_VAPI)
+ if(STATIC_ONLY)
+ message(FATAL_ERROR
+ "You are attempting to build the Vala api, however that option is not supported "
+ "when building static libraries only. "
+ "Please disable the static only option (-DSTATIC_ONLY=False) "
+ "if you really want to build the Vala api. Alternatively, "
+ "you can disable this feature (by passing -DICAL_GLIB_VAPI=False to cmake).")
+ endif()
if(NOT GOBJECT_INTROSPECTION)
message(FATAL_ERROR
"You requested to build the Vala vapi but have not enabled the GObject Introspection. "