summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Winter <allen.winter@kdab.com>2018-01-21 12:44:56 -0500
committerAllen Winter <allen.winter@kdab.com>2018-01-21 12:44:56 -0500
commitbf9e0b3c7909f316e8b33b12e21ccda6c6d9681f (patch)
tree811a31c74373d0704fab0ce5fb44256a82909427 /CMakeLists.txt
parent31586f528c03d27e512b715be21166cacf1d61ff (diff)
downloadlibical-git-bf9e0b3c7909f316e8b33b12e21ccda6c6d9681f.tar.gz
CMakeLists.txt, docs/CMakeLists.txt, Install.txt - new CMake option ICAL_BUILD_DOCS
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 15 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e9e9ad8f..99685ec7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -38,6 +38,10 @@
# Requires GObject Introspection development package v0.6.7 or higher
# Default=false (do not generate the introspection files)
#
+# -DICAL_BUILD_DOCS=[true|false]
+# Configure for the API documentation and User Manual. The 'docs' target will not be available.
+# Default=true
+#
# -DICAL_GLIB_VAPI=[true|false]
# Set to build Vala "vapi" files
# Requires Vala package
@@ -319,6 +323,13 @@ if(GOBJECT_INTROSPECTION)
endif()
endif()
+option(ICAL_BUILD_DOCS "Build documentation" True)
+add_feature_info(
+ "Option ICAL_BUILD_DOCS"
+ ICAL_BUILD_DOCS
+ "build API documentation and reference manual"
+)
+
option(ICAL_GLIB_VAPI "Build Vala \"vapi\" files.")
add_feature_info(
"Option ICAL_GLIB_VAPI"
@@ -544,7 +555,6 @@ endif()
################# build subdirs ########################
add_subdirectory(design-data)
-add_subdirectory(doc)
add_subdirectory(scripts)
add_subdirectory(test-data)
add_subdirectory(src)
@@ -554,6 +564,10 @@ if(USE_BUILTIN_TZDATA)
add_subdirectory(zoneinfo)
endif()
+if(ICAL_BUILD_DOCS)
+ add_subdirectory(doc) # needs to go last, for the build source files
+endif()
+
########### create and install pkg-config file #########
set(VERSION "${LIBICAL_LIB_VERSION_STRING}")