summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Winter <allen.winter@kdab.com>2014-10-11 10:07:58 -0400
committerAllen Winter <allen.winter@kdab.com>2014-10-11 10:07:58 -0400
commitc6409d1740846d9fc5618f824c4befb1995bf45e (patch)
treeb997bcfc4ae25a0601d21d76ac417b11ca019099 /CMakeLists.txt
parentda69aae790f680b633100475cac14c776fbda722 (diff)
downloadlibical-git-c6409d1740846d9fc5618f824c4befb1995bf45e.tar.gz
Copy in the RSCALE support feature
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d5aad80c..c96d97ba 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -94,6 +94,17 @@ endif()
# must have Perl to create the derived stuff
find_package(Perl REQUIRED)
+# libicu is highly recommended for RSCALE support
+# libicu can be found at http://www.icu-project.org
+# RSCALE info at http://tools.ietf.org/html/draft-daboo-icalendar-rscale
+find_package(ICU)
+if(ICU_FOUND)
+ set(HAVE_LIBICU 1)
+endif()
+if(ICU_I18N_FOUND)
+ set(HAVE_LIBICU_I18N 1)
+endif()
+
# MSVC specific definitions
if(WIN32)
if(MSVC)