summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Winter <allen.winter@kdab.com>2021-03-18 09:28:26 -0400
committerAllen Winter <allen.winter@kdab.com>2021-03-18 09:28:26 -0400
commitd15b93240a5c0223616e355e422d829802f33a0d (patch)
tree63e6011b5bd22c7e8ed3f1ce08d5a81b76b6bc9e /CMakeLists.txt
parent5b1ac2faff6de571b6eb30a0170b2b61a9b2e9b7 (diff)
downloadlibical-git-d15b93240a5c0223616e355e422d829802f33a0d.tar.gz
no longer support MSVC versions less then 2013
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bae56128..f4546599 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -108,6 +108,18 @@ set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${CMAKE_CURRENT_SOURCE_DIR}/cmake/mod
include(LibIcalMacrosInternal)
include(FeatureSummary)
+# Exit for blacklisted compilers that don't support necessary C standards
+# MSVC++ < 2013 aka 1800
+set(BAD_C_MESSAGE "")
+if(MSVC)
+ if(MSVC_VERSION LESS 1800)
+ set(BAD_C_MESSAGE "MSVC 2013 or higher")
+ endif()
+endif()
+if(BAD_C_MESSAGE)
+ message(FATAL_ERROR "\nSorry, ${BAD_C_MESSAGE} is required to build this software. Please retry using a modern C compiler that supports the C99 standard.")
+endif()
+
# Enable the test harness
enable_testing()