summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMarkus Minichmayr <markus@tapkey.com>2022-02-23 15:20:19 +0100
committerAllen Winter <allen.winter@kdab.com>2022-06-03 11:17:08 -0400
commitd88473bc53f32a54f18d976a97cc4d39f8902848 (patch)
tree919645b4eba3d0d12438a025a02d27bbff661e35 /CMakeLists.txt
parentc883bc9fff66ed4579ec39f10c48b083dbec9f3a (diff)
downloadlibical-git-d88473bc53f32a54f18d976a97cc4d39f8902848.tar.gz
Introducing config_public.h.cmake, which contains configuration to be included in ical.h.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f88bf312..062f3de8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -392,6 +392,7 @@ endif()
include(ConfigureChecks.cmake)
add_definitions(-DHAVE_CONFIG_H)
+configure_file(config_public.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config_public.h)
configure_file(config.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config.h)
set(INSTALL_TARGETS_DEFAULT_ARGS