summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Winter <allen.winter@kdab.com>2022-02-20 13:01:47 -0500
committerAllen Winter <allen.winter@kdab.com>2022-02-20 13:01:47 -0500
commite3b0c92c4b478ce8d3d83da5977595e30a988635 (patch)
treea8b62d21b6047e05cb7a3831d938c8d97e7868ac /CMakeLists.txt
parentac58828ee1108239145dbb0976522bc8e9e7fe73 (diff)
downloadlibical-git-e3b0c92c4b478ce8d3d83da5977595e30a988635.tar.gz
CMakeLists.txt - force debug of LIBICAL_DEV_MODE_MEMORY_CONSISTENCY
if LIBICAL_DEV_MODE_MEMORY_CONSISTENCY then build in debug mode
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3f726faa..43575d81 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -547,6 +547,7 @@ endif()
libical_option(LIBICAL_DEVMODE_MEMORY_CONSISTENCY "(Developer-only) Build with memory consistency functions." False)
if(LIBICAL_DEVMODE_MEMORY_CONSISTENCY)
+ set(CMAKE_BUILD_TYPE "Debug")
add_definitions(-DMEMORY_CONSISTENCY)
endif()
mark_as_advanced(LIBICAL_DEVMODE_MEMORY_CONSISTENCY)